ТАУ ЮНИТА 1 Математическое описание линейных систем и их элементов

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ
РЕСПУБЛИКИ КАЗАХСТАН

Рудненский индустриальный институт

ДИСТАНЦИОННОЕ ОБРАЗОВАНИЕ

Рабочий учебник

ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ

ЮНИТА 1

Математическое описание линейных систем и их элементов

Электронная версия 1.26
3.08.2008

Рудный 2008

ББК 33.98

Автор: Федосов Б.Т. , к.т.н., доцент

Рецензент: Родионов С.А., к.т.н., ст. преподаватель

Рекомендовано к изданию УМС РИИ

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ

Юнита 1. Математическое описание линейных систем и их элементов
Юнита 2. Анализ линейных систем автоматического регулирования
Юнита 3. Оптимизация систем управления
Юнита 4. Нелинейные и импульсные системы
автоматического регулирования

ЮНИТА 1

Изложены основные понятия теории автоматического управления. Даны определения и способы математического описания систем управления и их элементов. Рассмотрены виды схем САР (систем автоматического регулирования), структурная реализация алгоритмов управления, типовые звенья САР, способы соединения звеньев, схема типовой САР.

Изложение ориентируется на использование в курсе компьютерной программы объектно – ориентированного моделирования (ООМ) VisSim, однако при решении задач могут быть использованы и ее аналоги: русскоязычный программный комплекс ПК "МВТУ", пакет Simulink из программы MathLab и др., а также программа MathCAD.

  • Для студентов специальностей
    210440 "Электроснабжение промышленных предприятий"
    330840 "Электропривод и автоматизация технологических комплексов"
    091340 "Информационные системы в экономике"
    • 050702 "Автоматизация и управление"

Юнита соответствует типовой образовательной программе

© Б.Т.Федосов
Рудненский индустриальный институт 2008

Далее >>


ТАУ ЮНИТА 1 Содержание

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

СОДЕРЖАНИЕ

  • ТИТУЛЬНЫЙ ЛИСТ
  • ТЕМАТИЧЕСКИЙ ПЛАН
  • ЛИТЕРАТУРА
  • ТЕМАТИЧЕСКИЙ ОБЗОР

    • Лекция 1
  • Вступление
    •
  • Введение
    •
    • Цели и задачи курса
    • Предмет курса ТАУ
    • Значимость курса ТАУ
  1. Характеристика объектов и систем автоматического управления
    2.
    • 1.1. Понятия и определения
      •
    • 1.2. Объекты управления. Воздействия и реакции
      •
      • 1.2.1. Объект управления
        •
      • 1.2.2. Воздействия и реакции Терминология
        •
    • 1.3. Физические и алгоритмические модели объектов и систем
    • 1.4. Принципы автоматического управления
      • 1.4.1. Задачи решаемые САУ
        •
      • 1.4.2. Структурная реализация принципов управления
        •
        • 1.4.2.а, разомкнутая САР с жестким управлением
          •
        • 1.4.2.б, разомкнутая САР с управлением по возмущению
          •
        • 1.4.2.в, замкнутая САР с управлением по отклонению
          •
        • 1.4.2.г, комбинированная схема с управлением
          по отклонению и возмущению
        • 1.4.2.д, экстремальные системы
      • 1.4.3. Режимы работы САР
        •
          Статика. Установившийся режим. Переходный режим
      Заключение
      Вопросы для самопроверки
    Лекция 2
  2. Уравнения, модели и характеристики линейных систем
    3.
    • 2.1. Математические модели систем, воздействий и реакций
      •
      • 2.1.1. Дифференциальные уравнения линейных объектов и систем
      • 2.1.2. Простейшие сигналы
        • 2.1.2.а, гармонический сигнал
          •
        • 2.1.1.б, ступенчатая единичная функция
          •
        • 2.1.1.в, дельта - функция Дирака
          •
        • 2.1.1.г, степенная функция
          •
    • 2.2. Характеристики линейных объектов
      • 2.2.1. Передаточная функция
      • 2.2.2. ККП – комплексный коэффициент передачи
      • 2.2.3. Переходная функция
      • 2.2.4. Весовая или импульсная функция
      Заключение
      Вопросы для самопроверки
    Лекция 3
  3. Типовые звенья и идентификация САР
    4.
    • 3.1. Определение. Классификация звеньев
      •
    • 3.2. Простейшие звенья
      •
      • 3.2.1. Пропорциональное звено
      • 3.2.2. Интегрирующее звено
        •
    • 3.3. Типовые звенья I порядка
      •
      • 3.3.1. Апериодическое (инерционное) звено
        •
      • 3.3.2. Форсирующее (ускоряющее) звено
        •
      • 3.3.3. Инерционно - дифференцирующее звено
        •
    • 3.4. Колебательное звено
      •
    • 3.5. Звено запаздывания
    • 3.6. Идентификация линейных САР и их элементов
      •
    • Заключение
      •
      Вопросы для самопроверки
    Лекция 4
  4. Соединение звеньев и преобразование структурных схем.
    Типовая схема САР
    • 4.1. Теоремы о соединении звеньев
      • 4.1.1. Последовательное соединение
      • 4.1.2. Параллельное согласное соединение
      • 4.1.3. Параллельное встречное соединение
        (системы с обратной связью)
    • 4.2. Преобразование схем с использованием переносов ветвлений
      и сумматоров через звено
    • 4.3. Типовая одноконтурная САР
      • 4.3.1. Передаточная функция W(p) разомкнутого контура
      • 4.3.2. Передаточная функция Фз(p) замкнутой САР
        по каналу управления
      • 4.3.3. Передаточная функция Фез(p) замкнутой САР по ошибке,
        обусловленной заданием
      • 4.3.4. Передаточная функция Фв(p) замкнутой САР
        по возмущению
      • 4.3.5. Уравнения динамики и статики типовой САР
        •
    • 4.4. Многомерные системы управления
    • Заключение

      • Вопросы для самопроверки
  • ФАЙЛ МАТЕРИАЛОВ (справочные материалы)
  • ПЕРЕЧЕНЬ УМЕНИЙ
  • ПЕРЕЧЕНЬ ЗНАНИЙ
  • ТРЕНИНГ УМЕНИЙ
  • САМОСТОЯТЕЛЬНАЯ РАБОТА
  • ГЛОССАРИЙ
  • Вопросы для самопроверки
  • Об авторе

Далее >>


ТАУ ЮНИТА 1 ТЕМАТИЧЕСКИЙ ПЛАН

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

ТЕМАТИЧЕСКИЙ ПЛАН

1. Характеристика объектов и систем автоматического управления

Объекты и системы управления. Воздействия и реакции. Физические и алгоритмические модели объектов и систем. Принципы автоматического управления. Задачи решаемые САУ. Структурная реализация принципов управления.

2. Уравнения, модели и характеристики линейных систем

Дифференциальные уравнения линейных объектов и систем. Простейшие сигналы – модели воздействий и реакций. Характеристики линейных объектов. Передаточная функция. ККП – комплексный коэффициент передачи. Переходная функция. Весовая или импульсная функция.

3. Типовые звенья

Определение. Классификация звеньев. Простейшие звенья. Пропорциональное звено. Интегрирующее звено. Типовые звенья I порядка. Апериодическое (инерционное) звено. Форсирующее (ускоряющее) звено. Инерционно - дифференцирующее звено. Колебательное звено. Звено запаздывания. Идентификация элементов САР.

4. Соединение звеньев и преобразование структурных схем. Типовая схема САР

Теоремы о соединении звеньев. Преобразование схем с использованием переносов ветвлений и сумматоров через звено. Типовая одноконтурная САР. Многомерные системы управления.

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 Литература

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Литература и Интернет

  1. Основная
    • 1.1. Лукас В.А. Теория автоматического управления. –М., :Недра, 1990г., 416 стр.;
    • 1.2. ТАУ, под ред. Ю.М. Соломенцева, - М., ВШ, 2002 г.
    • 1.3. Федосов Б.Т. Методические указания к выполнению лабораторных работ №0 - №6 по курсу ТАУ. Электронные документы в формате .chm справки Windows. - Рудный, РИИ, 2002 - 2006 гг.
      http://model.exponenta.ru/bt/bt_cont_3_Met.html#32
    • 1.4. Клиначев Н.В. ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ Учебно-методический комплекс
      http://online.download.ru/Download/[ProgramID=11415] или
      http://model.exponenta.ru/tau_knv.zip
      файл tau_knv.zip 1439 KB, V3.4, 28.08.2004
  2. Дополнительная
    • 2.1. Бесекерский В.А. Попов Ю.И. Учебник по ТАУ. - М., ВШ, 1972;
    • 2.2. Бесекерский В.А. Попов Ю.И. Задачник по ТАУ. - М., ВШ, 1972;
    • 2.3. Топчеев Ю.И., Цыпляков А.П. Задачник по ТАУ.- М., Машиностроение, 1977. – 592стр.
    • 2.4. Официальный сайт фирмы Visual Solution, производителя программы моделирования систем и объектов VisSim
      http://www.vissim.com;
    • 2.5. Сайт, посвященный ТАУ и моделированию систем и объектов в программах VisSim, ПК «МВТУ» и MVS
      http://model.exponenta.ru
    • 2.6.Официальный сайт программного комплекса "МВТУ" моделирования систем и объектов
      http://mvtu.power.bmstu.ru
    • 2.7. Федосов Б.Т. Экспресс-анализ САР по ее передаточной функции
      http://model.exponenta.ru/bt/bt_00111.html
    • 2.8. Федосов Б.Т. Задания и методические указания к выполнению курсовой работы по курсу ТАУ. Электронный документ в формате .chm справки Windows. - Рудный, РИИ, 2002 -2004 г.
    • 2.9. Федосов Б.Т. Задания и методические указания к выполнению лабораторной работы № 0 по курсам Информатика, Системотехника и ТАУ на тему: Первое знакомство с компьютером. Знакомство с операционной системой Windows. Рабочий стол. Стандартные программы: Блокнот, Калькулятор, Paint. Электронный документ в формате .chm справки Windows. - Рудный, РИИ, 2004 г.
    • 2.10. Федосов Б.Т. Теория автоматического управления и смежные вопросы. Моделирование. Сборник статей 2003 - 2006 гг.
      http://model.exponenta.ru/bt/bt_contents.html
    • 2.11. Федосов Б.Т. О методах описания линейных систем. Рудный, 2005
      http://model.exponenta.ru/bt/bt_001124.html )

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 Введение. Лекция 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вступление

Предлагаемый рабочий учебник для дистанционного обучения основан на кратком курсе из 8 - 9 лекций по теории автоматического управления, читаемом автором в четвертом семестре студентам второго курса специальности 210440 "Электроснабжение промышленных предприятий" в Рудненском индустриальном институте. Курс призван дать студентам общее, поверхностное представление о предмете ТАУ и ввиду своей краткости требует строгого подхода к отбору материала. Необходимо не только изложить то, что требуется, но и не сказать лишнего, чтобы не перегрузить курс.
Студентам других специальностей, изучающих ТАУ и системотехнику, в частности, 330840 "Электропривод и автоматизация технологических комплексов" и 091340 "Информационные системы в экономике" это учебное пособие может быть рекомендовано как вспомогательный и справочный материал для быстрого знакомства с предметом ТАУ.
Юнита 1 (рабочий учебник) представляет собой целостное методическое пособие по разделу курса ТАУ "Математическое описание линейных систем и их элементов", содержащее конспект лекций, информацию о том, что студент должен знать и уметь по окончанию изучения раздела и вспомогательные материалы. В совокупности с методическими указаниями по выполнению лабораторных работ [1.3] материал юниты 1 позволяет самостоятельно изучить раздел в полном объеме.
Большое внимание в учебнике уделено иллюстрациям, позволяющим существенно повысить плотность информации. Студентам рекомендуется подробно изучать рисунки.

Введение

1. Цели и задачи курса

ТАУ - общетехнический курс для инженеров специальности ЭЭ. Курс вводит в теорию автоматических систем управления, дает основные теоретические сведения, обеспечивающие понимание принципов функционирования систем управления и грамотную их эксплуатацию.

Цель дисциплины: изучение основных положений ТАУ и ознакомление с методами анализа и синтеза систем автоматического управления в объеме достаточном для грамотной эксплуатации систем управления и постановки задач по их проектированию и модернизации.

Задачи дисциплины:

  1. приобретение знаний
    • - основ теории систем автоматического управления;
    • - методов анализа и синтеза систем автоматического управления;
  2. приобретение навыков
    • - анализа систем автоматического управления ;
    • - оптимизации и синтеза систем автоматического управления;
    • - моделирования и исследований систем автоматического регулирования в современной программной среде объектно - ориентированного моделирования (ООМ) систем (VisSim, ПК "МВТУ" и др.).

2. Предмет курса ТАУ

ТАУ – это научная и техническая дисциплина, она изучает общие принципы системной организации на основе построения математических моделей объектов и систем управления. Это позволяет оценивать характеристики и свойства проектируемых систем, создавать системы, отвечающие заданным требованиям качества.

Анализ - исследование системы управления, путем построения ее математической модели и изучения свойств этой модели. Анализ проводится с целью выяснения вопроса о том, способна ли в принципе модель САР решать задачу управления, и если нет, то какими методами и средствами ее можно сделать работоспособной.

Синтез – (теоретическое конструирование) – это построение модели системы управления, обеспечивающей требуемое поведение объекта управления.

Этапы проектирования системы управления

  1. объект управления: выбирается объект управления. Определяются цели его функционирования, управляемые величины и воздействия, которые могут быть приложены к его входам.
  2. на основании инженерного опыта, интуиции строится функциональная схема системы управления, которая, в принципе, способна решить поставленную задачу управления объектом.
  3. модель. По функциональной схеме строится модель системы управления. Модель представляет собой так называемую структурную схему, отображающую взаимодействие элементов модели, а также набор передаточных функций, описывающих отдельные элементы структуры.
  4. анализ модели. Изучаются свойства и характеристики модели. Определяется ее работоспособность, а также характеристики качества, в первую очередь, точность и быстродействие.
  5. синтез САР. Синтез – теоретическое конструирование. Здесь оптимизируются параметры и структура системы управления, с тем, чтобы обеспечить требуемое качество САР.
  6. техническая реализация.

3. Значимость курса ТАУ

ТАУ – теоретическая основа построения и исследования полноценных функционирующих систем управления, выполняющих полезные для человека функции.

1. Характеристика объектов и систем автоматического управления

1.1. Понятия и определения

ТАУ (теория автоматического управления) – это научно-техническая дисциплина, изучающая и развивающая методы анализа и синтеза моделей систем управления.

Кибернетика – наука об управлении. Основывается на изучении процессов протекающих в объектах управления, на изучении того, как эти объекты реагируют на внешние воздействия и определении способов воздействия на объект с тем, чтобы оптимизировать его состояние и поведение.

Объектами управления в кибернетике могут быть устройства, машины, живые организмы, их органы, коллективы людей, популяции животных и т.п.

Автоматическое управление – это осуществление совокупности воздействий, выбранных из множества возможных, на объект управления, с целью оптимизировать в определенном заданном смысле его состояние и поведение.

Автоматическое регулирование – это поддержание постоянной или меняющейся по некоторому закону во времени какой-то величины, характеризующей объект управления. Величина должна меняться требуемым образом вопреки препятствующим этому факторам

1.2. Объекты управления. Воздействия и реакции

1.2.1. Объект управления

Объект управления (ОУ) в ТАУ – это устройство, машина или процесс и др., которые характеризуются некоторыми физическими величинами. Эти величины могут быть измерены. Объект управления способен воспринимать внешние воздействия и реагировать на них изменением значений выходных величин.

Объектами управления в технике могут быть машины, механизмы, электромеханические устройства, более простые САР и др.

Рис.1.1. Обозначение объекта управления (ОУ) на функциональной схеме. x(t) - воздействие на объект, y(t) – реакция объекта, отклик на воздействие

С точки зрения ТАУ не так важно, из каких физических элементов состоит объект управления (ОУ), куда важнее знать, как объект реагирует на внешние воздействия.

Различают статический и динамический режимы работы объекта или системы управления. В статике все сигналы (воздействия и реакции) постоянны, инерционность элементов САР не проявляется. В динамике воздействия, а следовательно и отклики, реакции объектов и систем, изменяются, что приводит к проявлению инерционных свойств объектов.

Характеристики ОУ:

Статическая характеристика – зависимость выходной величины объекта у, т.е. величины характеризующей объект управления, от величины подаваемого на его вход воздействия х, при условии, что подаваемое воздействие постоянно, т.е. х = const.

Рис. 1.2. Примеры статических характеристик объектов управления. 1 – линейная характеристика; 2,3 – нелинейные характеристики

При малых изменениях воздействий, как правило, любой объект является линейным. Т.е. малые изменения воздействий приводят к малым изменениям реакций, пропорциональным изменению воздействий.

Характеристики объекта:

  1. диапазон линейности статической характеристики;
  2. быстродействие – определяется инерционностью объекта;
  3. чувствительность (крутизна статической характеристики)

  • Свойства объекта:
  • - линейность:
    • - способность к усилению или ослаблению (пропорциональность, линейность);
    • - способность к накоплению (элементарная инерционность);
    • - прогнозируемость (позволяет в установившемся режиме предсказывать значение выходной величины);
    • - способность к самовыравниванию (способность сопротивляться действию внешней силы, уравновешивать ее) и
    • - отсутствие самовыравнивания (реагирование на постоянное внешнее воздействие непрерывным бесконечным с течением времени монотонным изменением выходной величины);
    • - колебательность;
    • - способность терять устойчивость (потеря возможности управления объектом с помощью управляющего воздействия);
    • - запаздывание (отражает протяженность объекта в пространстве посредством учета времени, необходимого для передачи воздействий от одного элемента к другому);
  • - нелинейность.

1.2.2. Воздействия и реакции. Терминология

  • а) входные и выходные величины;
  • б) управляющие и управляемые величины
    Управляющие величины подают на вход объекта и под их действием изменяются управляемые (выходные) величины;
  • в) контролируемые и неконтролируемые
    Контролируемые величины измеряются в процессе управления;
  • г) задающие и возмущающие.
    Задающая (отслеживаемая) величина – величина, в соответствии с которой должна изменяться управляемая величина объекта. Эта величина подается на вход САР.
    Возмущающая величина характеризует совокупность факторов, причин, воздействующих на объект управления и препятствующих его требуемому поведению. Эта величина моделирует неизбежные помехи, влияющие на поведение объекта управления.

Примеры ОУ:

Рис. 1.3. Резервуар – теплообменник. Контролируемая величина: температура жидкости. Изменение возмущения – температуры подаваемой холодной воды (синяя пунктирная кривая) приводит к изменению температуры воды в резервуаре (желтая кривая), которое постепенно компенсируется дополнительным подогревом (красный пунктир). В результате контролируемая температура возвращается к своему нормальному значению

Рис.1.4. Двигатель постоянного тока (ДПТ). Управляющая величина - напряжение якоря, управляемая величина – частота вращения вала, возмущение – момент сопротивления на валу

1.3. Физические и алгоритмические модели объектов и систем

Функциональная и структурная (структурно-алгоритмическая) схемы это условные графические изображения физического состава объекта или системы управления, и его математического описания.

Функциональная схема состоит из блоков соответствующих функциональным, физически существующим элементам объектов, а стрелки указывают на направление передачи энергии между ними.

Пример:

Рис.1.5. Пример функциональной схемы. Г – генератор; ТП – тиристорный преобразователь; ДПТ – двигатель постоянного тока

Структурная (структурно-алгоритмическая) схема – состоит из звеньев, соответствующих математическим операциям преобразования сигналов; стрелки между блоками указывают направление передачи информации (сигналов).

Пример:

Рис 1.6. Фрагмент структурной схемы. Показаны сумматор, пропорциональное звено и интегратор

Замечание: в структурной схеме в блок может входить только одна стрелка, за исключением сумматора и перемножителя сигналов.

Примечание. Функциональная схема объекта единственна и может отличаться лишь глубиной, подробностью отображения элементов объекта. Структурных схем для одного и того же объекта может быть составлено несколько разных, причем все они будут эквивалентны между собой. Структурная схема – это особого вида математическая модель объекта или системы управления.

1.4. Принципы автоматического управления

    САР широко используются на практике, например, для того, чтобы:
  • - управлять с помощью маломощного источника, в том числе дистанционно, мощным объектом;
  • - стабилизировать значение некоторой величины, т.н. управляемой, характеризующей объект. При стабилизации с должной точностью, определяемой технологией, продукт выдаваемый объектом управления, будет иметь требуемое высокое качество;
  • - следить, т.е. осуществлять такое управление объектом, при котором его управляемая величина будет с достаточной точностью и практически все время пропорциональна некоторой т.н. задающей величине. Это задание определяется технологией, например температура в обжиговой печи циклического действия должна изменяться с течением времени по заданной циклограмме.
    Виды управления техническими объектами:
  • - непрерывное, когда управляющее воздействие меняется практически все время непрерывно и достаточно плавно;
  • - дискретное, например, типа включить - выключить.

Вид управления в САР определяется типом ее регулятора, который может быть непрерывным (аналоговым), дискретным или дискретно-цифровым. Дискретно-цифровой регулятор в принципе способен управлять объектом как непрерывно, так и дискретно.

Регулятор это устройство, вырабатывающее управляющее воздействие и подающее его на объект управления. Воздействие вырабатывается такое, чтобы объект вел себя требуемым образом, и вырабатывается оно на основе задания, измерения возмущения и управляемой величины или только некоторых из этих величин. Алгоритмы работы регуляторов и принцип их действия будут рассмотрены в последующих юнитах.

    САР бывают
  • - технические и кибернетические (с искусственным интеллектом);
  • - стабилизации, слежения и самонастраивающиеся на заданный оптимум функционирования;
  • -замкнутые, с управлением по отклонению, разомкнутые с жестким управлением и управлением по возмущению, комбинированные, и одномерные и многомерные;
  • - устойчивые и неустойчивые;
  • - статические и астатические;
  • - линейные, нелинейные, с непрерывным и с дискретным управлением.

    • 1.4.1. Задачи решаемые САУ:

    1. Стабилизация
      Стабилизация в узком смысле это поддержание постоянной некоторой величины характеризующей объект, вопреки действующим на него возмущениям.
      Решая такую задачу стабилизации, САР заставляет с некоторой точностью управляемую величину объекта управления оставаться постоянной при изменении возмущения.
      Пример: САР стабилизации температуры утюга на уровне, заданном домохозяйкой.
      Стабилизация в широком смысле состоит в том, что САР в значительной мере или полностью компенсирует влияние возмущений на управляемую величину. Это значит, что если возмущение, поступающее на объект, изменяет управляемую величину, то правильно работающая САР через сравнительно короткое время возвращает управляемую величину к исходному значению.
    2. Слежение (частный его случай - программное управление)
      Слежение – это изменение некоторой величины, характеризующей объект (управляемой величины), в соответствии с другой величиной, задающей (отслеживаемой), закон изменения которой во времени заранее не известен.
      Программное управление – это изменение некоторой величины характеризующей объект, в соответствии с заранее известной функцией времени.
      Проще говоря, решая задачу слежения, САР заставляет управляемую величину объекта управления быть пропорциональной задающей (отслеживаемой) величине.
      Часто САР способны решать обе задачи: и слежении, и стабилизации.
      Стабилизация и слежение (программное управление) осуществляются как разомкнутыми, так и замкнутыми системами управления.
    3. Самонастройка системы
      Самонастройка системы – это поддержание некоторой величины, характеризующей объект, на оптимальном значении в соответствии с выбранным заранее критерием.
      Самонастраивающаяся система в процессе управления может менять параметры своих элементов и даже структуру.

    1.4.2. Структурная реализация принципов управления

    Существуют разомкнутые и замкнутые системы автоматического регулирования. Разомкнутые – просты, но не точны. В ряде случаев, например, при регулировании объектов с запаздыванием, они имеют преимущество перед замкнутыми системами по быстродействию. Замкнутые системы позволяют получить хорошую точность и быстродействие, но при неправильной настройке могут терять устойчивость, т.е. перестают решать требуемую задачу.

    1.4.2.а, разомкнутая САР с жестким управлением

    Схема используется для программного управления.

    Рис. 1.7. Функциональная схема разомкнутой САР с жестким управлением. хз – задание, в соответствии с которым изменяется управляемая величина y(t). На регулятор подается только задающая величина

    Задание хз(t) – это функция времени, определяющая, как должна вести себя управляемая величина y(t). Задание задает или человек – оператор, или программное устройство, или компьютер. Регулятор в соответствии с заданием хз, вырабатывает управляющее воздействие u. В рассматриваемой схеме регулятор не имеет информации ни об истинном состоянии объекта y(t), ни о возмущениях xв(t), которые на него действуют.

    Схема может быть применена, тогда, когда хв приблизительно равно нулю, т.е. возмущение пренебрежимо мало, или хв(t) – может быть предвычислено с достаточной точностью и предварительно учтено в задании.

    Т.о. САР с жестким управлением способна решать задачу слежения, но не может решать задачу стабилизации.

    1.4.2.б, разомкнутая САР с управлением по возмущению

    Схема используется для программного управления и стабилизации.

    Рис 1.8. Функциональная схема разомкнутой САР с управлением по возмущению. Управляющее воздействие u формируется регулятором на основе задания хз(t) и с учетом возмущения хв(t).

    Пример применения САР с управлением по возмущению.
    Поддержание постоянства уровня жидкости в емкости, когда этот уровень невозможно измерять непосредственно, но можно измерять расход и скорость поступления жидкости в емкость.

    1.4.2.в, замкнутая САР с управлением по отклонению

    Схема используется для слежения, программного управления и стабилизации.

    В такой системе регулятор в процессе управления учитывает как задание, так и реальное состояние объекта, а, кроме того, косвенно учитывает и возмущение.

    Рис. 1.9. Функциональная схема замкнутой САР с управлением по отклонению. e(t) – отклонение (ошибка слежения, регулирования) управляемой величины y(t) от задания хз(t). Основные элементы схемы: объект управления, контур главной обратной связи

    Сравнивающее устройство (сумматор) сравнивает задающую и управляемые величины и вычисляет отклонение, ошибку регулирования e(t) = хз(t) - y (t).

    Регулятор – вырабатывает такое управляющее воздействие u(t) на объект управления, которое сводит ошибку к нулю или допустимому минимуму. В идеале, когда e = 0, хз(t) = y (t)

    Работа системы в статике

    В статике переходные процессы уже закончились. Все сигналы уравновешены и сбалансированы. При текущем значении задания хз(t) = const отклонение e (ошибка регулирования) постоянна и ее величина такова, что регулятор вырабатывает управляющее воздействие u, обеспечивающее значение управляемой величины, дающее после вычитания из задания тот сигнал ошибки, который и есть. Причин для изменения сигналов нет и величина сигнала ошибки мала. Поэтому управляемая величина приблизительно (или точно) равна или пропорциональна заданию.

    Работа системы в динамике

    Слежение

    Пусть сейчас система находится в установившемся режиме и e = 0. В какой-то момент времени задание начинает хз(t) расти. Поскольку регулятор и объект управления инерционные, то управляемая величина в первые моменты времени не успевает возрасти. Поэтому отклонение е возрастает. Учитывая это возрастание регулятор увеличивает управляющую величину, объект воспринимает это увеличение и реагирует на него увеличением управляемой величины. Это приводит к уменьшению отклонения. Контур отрицательной обратной связи (ООС) замкнулся. Регулятор продолжает изменять управляющую величину до тех пор, пока отклонение не уменьшится до малой и даже нулевой величины. Тем самым управляемая величина подтягивается к заданию, следит за заданием. Контур осуществляет ООС, что при повышении ошибки регулирования приводит, может быть постепенно во времени, к ее уменьшению.

    Регулятор имеет информацию о состоянии объекта, поскольку отклонение определяется вычитанием управляющей величины из задания.

    Стабилизация (компенсация возмущения)

    Изменение возмущения приводит к отклонению управляемой величины от ее требуемого значения. Это немедленно сказывается на отклонении (ошибке регулирования). Регулятор на основании этого изменения отклонения так изменяет управляющую величину, что отклонение уменьшается. Контур отрицательной обратной связи (ООС) замкнулся. Влияние изменения возмущения компенсируется, т.е. осуществляется стабилизация.

    Итак, принцип работы САР с управлением по отклонению основывается на свойстве контура, образованного отрицательной обратной связью с выхода объекта, устремлять к нулю сигнал на выходе сумматора.

    1.4.2.г, комбинированная схема с управлением по отклонению и возмущению

    Эта схема обладает наилучшими свойствами и чаще других используется как для слежения, так и для стабилизации и программного управления при решении задач, в которых требуется получить высокие точность и быстродействие.

    Рис. 1.10. Функциональная схема САР с комбинированным управлением по отклонению и по возмущению

    Возмущение измеряется непосредственно или косвенно и подается на регулятор для коррекции управляющей величины, что позволяет быстро в значительной мере компенсировать влияние возмущения на управляемую величину. Недокомпенсацию существенно уменьшает контур управления по отклонению, который в итоге и обеспечивает требуемую точность слежения.

    1.4.2. д, экстремальные системы

    Система экстремального управления обеспечивает такое поведение объекта, при котором управляемая величина достигает экстремума (максимума или минимума).

    Рис.1.11. Система экстремального управления

    Рис.1.11. Система экстремального управления

    Подавая пробное малое приращение управляющей величины на объект, регулятор определяет возрастает ли или убывает при этом управляемая величина. И в зависимости от того, требуется достигнуть максимума или минимума, регулятор увеличивает или уменьшает управляемую величину до тех пор, пока малые изменения управляемой величины перестанут приводить к изменению управляемой.

    Принцип управления: (буровой станок)

    Рис. 1.11. Оптимальная скорость бурения достигается тогда, когда производная скорости по давлению на долото равна нулю. Отклонение давления от оптимального значения приводит к появлению положительной или отрицательной производной скорости по давлению, что позволяет регулятору вырабатывать сигнал компенсации, который определяет направление изменения давления на долото.

    1.4.3. Режимы работы САР

    Системы автоматического регулирования предназначены для того, чтобы поддерживать управляемую величину объекта пропорциональной задающей величине с требуемой точностью.

    Слежение это задача, наиболее часто решаемая системами автоматического управления. Так, стабилизация это частный случай слежения, когда задание не изменяется, или часть задачи, решаемой САР при слежении.

    В зависимости от того, как изменяется во времени задающая (отслеживаемая) величина, различают три режима работы САР:

    • - статический (статика);
    • - установившийся (динамика);
    • - переходный (также динамика).

    Статика

    При эксплуатации промышленных систем автоматического регулирования они очень часто достаточно длительное время работают в статическом режиме.

    Суть статического режима проста: задающая, а также возмущающая величины не изменяются во времени. Правильно работающая САР обеспечивает с точностью, не хуже требуемой пропорциональность управляемой величины управляющей величине. Математически этот процесс выражается т.н. уравнением статики, очень просто связывающим выходную, управляемую величину Y с заданием x и возмущением V:

    (1.1)

      где:
    • - kx это коэффициент пропорциональности, который может иметь размерность;
      - kv это коэффициент пропорциональности, величина которого или относительно очень мала, или равна нулю.

    Малость коэффициента пропорциональности kv между возмущением и управляемой величиной и приводит к тому, что выходная величина поддерживается с нужной точностью пропорциональной входной.

    (1.2)

    Физически это означает, что внутри САР все величины уравновешены.

    Статика управления наглядна и прозрачна: чем больше задание, тем больше управляемая величина, вот все что требуется от любой САР.

    Установившийся режим

    Это режим работы, при котором задание и (или) возмущение, действующие на САР и объект управления, в течение ограниченного времени достаточно плавно и непрерывно изменяются. Установившийся режим работы очень важен, потому что САР на протяжении практически всего времени работает в нем, если учитывать то, что статический режим есть частный случай установившегося.

    В установившемся режиме выходная, управляемая величина объекта управления является функцией времени и зависит не только от текущего значения задания, но и от его производных по времени:

    (1.3)

    Здесь gi и bi - это коэффициенты отклика САР на изменение задания и возмущения соответственно по скорости, ускорению и т.д. изменения воздействий [Федосов Б.Т. Переходный и установившийся режимы системы автоматического управления. Причины возникновения, описание, сходства и различия. 6. О приближенном описании установившегося режима. http://model.exponenta.ru/bt/bt_0003.html#19. Рудный, 2003].

    Как видно, для того, чтобы САР продолжала, как и в статике, отвечать своему назначению, а именно обеспечивать пропорциональность управляемой величины управляющей, необходимо, чтобы производные воздействий были достаточно малы, т.е. воздействия изменялись бы достаточно медленно. Другими словами, коэффициенты отклика характеризуют быстродействие САР в установившемся режиме.

    С физической точки зрения, САР, состоящая из взаимодействующих элементов, в установившемся режиме, при изменении воздействий успевает, напрягаясь, противодействовать изменению воздействий, и поэтому она реагирует на воздействия как целое.

    Переходный режим

    САР оказывается в переходном режиме при резких, например ступенчатых, изменениях воздействий и их младших производных. Термин "переходный" характеризует тот факт, что в течение некоторого времени САР переходит из одного установившегося или статического режима в другой.

    При сравнительно малых ступенчатых или шумовых изменениях воздействий ошибки регулирования, обусловленные переходным режимом, могут и не выходить за пределы допустимой точности слежения или стабилизации. И тогда эти переходные процессы малозначимы. По существу на практике такие незначительные переходные процессы происходят в течение всего времени работы САР.

    Однако ступенчатые изменения могут в некоторых случаях быть и весьма большими. В этом случае ошибки переходного режима могут оказаться куда больше допустимых. И в течение длительности переходного процесса, сравнительно недолго, САР перестает выполнять свои функции с должным качеством, поскольку ошибки регулирования превышают допустимые значения.

    С физической точки зрения САР во время переходного процесса реагирует на воздействие не только как целое, но резкие изменения воздействий приводят еще и к обмену энергией между элементами системы, апериодического или колебательного характера. Эти переходные процессы в устойчивой системе со временем затухают.

    Переходный режим описывается дифференциальными уравнениями, одним или несколькими.

    Заключение

    Системы автоматического регулирования предназначены для того, чтобы поддерживать управляемую величину объекта пропорциональной задающей величине с требуемой точностью. Т.о., закон изменения во времени задания повторяется управляемой величиной. Задание, как правило, маломощный сигнал. САР позволяет с помощью этого маломощного сигнала управлять мощным объектом.

    Далее >>

    К содержанию >>


1 Вопросы для самопроверки ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки по теме 1

Характеристика объектов и систем автоматического управления

  • Вопрос 1.1
    Укажите схему разомкнутой САР с жестким управлением
  • Вопрос 1.2
    Укажите схему разомкнутой САР с управлением по возмущению
  • Вопрос 1.3
    Укажите схему замкнутой САР с управлением по отклонению
  • Вопрос 1.4
    Укажите схему замкнутой САР с комбинированным управлением по отклонению и возмущению
  • Вопрос 1.5
    Укажите схему САР с экстремальным управлением

<< К темам вопросов

К главе 2 >>

К содержанию
лекций >>


ТАУ ЮНИТА 1 Лекция 2

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

2. Уравнения, модели и характеристики линейных систем

Линейная система управления – это такая система, реакция которой на сумму воздействий равна сумме реакций на каждое из них, а некоторому масштабному изменению воздействия соответствует пропорциональное изменение реакции. При малых воздействиях или их приращениях большинство систем может рассматриваться как линейные.

2.1. Математические модели систем, воздействий и реакций

Математические модели объектов и систем автоматического управления строятся с целью их исследования и построения на его основе моделей оптимальных, отвечающих требованиям заказчика систем.

2.1.1. Дифференциальные уравнения линейных объектов и систем

Дифференциальное уравнение – связывает воздействие на систему и ее реакцию на это воздействие. Воздействие это входной сигнал системы, а реакция – её выходной сигнал. Дифференциальное уравнение это математическая модель системы или объекта управления.

Системы и их элементы воспринимают воздействия или их составляющие, реагируя появлением смещения (закон Гука), скорости (в вязкой среде), ускорения (в инерционной среде, II закон Ньютона) и более высоких производных. При этом справедлив III закон Ньютона, он то и позволяет приравнять воздействие и совокупную реакцию элементов системы. В результате, после преобразования равенство (уравнение) можно привести к виду в котором в явной или неявной форме связаны воздействия и реакции.

В общем виде объекты и системы описываются нелинейным дифференциальным уравнением, связывающим воздействие u(t) на систему и его производные по времени с реакцией v(t) системы и ее производными::

(2.1)

Для его однозначного решения нужно задать начальные условия (НУ):

  • v(0) = ...;
  • v’(0) = ...;
  • v’’(0) = ...;
  • ...
  • v(n-1)(0) = ....

Зачастую при управлении нелинейными объектами приращение управляющих воздействий и их производных малы по сравнению со стационарными значениями, поэтому система может быть линеаризована, т.е. нелинейное дифференциальное уравнение может быть заменено линейным относительно этих приращений:

(2.2)

где приращения x, y – малы,
для приращений начальные условия нулевые.

Коэффициенты ai и kj определяются рабочей точкой, в которой осуществлена линеаризация.

В уравнении (2.2) известны коэффициенты, они определяются свойствами системы, воздействие x(t) – функция времени, и начальные условия – они нулевые. Искомой величиной является функция времени y(t) – реакция, отклик системы на воздействие x(t).

    Методы решения дифференциальных уравнений (ДУ):
  • - апостериорные
    • - классический;
    • - операторный;
    • - спектральный;
  • - методы текущего (реального) времени:
    • - численные методы решения ДУ (Эйлера, Рунге-Кутты и др.);
    • - интегралы Дюамеля и свертки;
    • - моделирования на аналоговых вычислительных машинах, а также на их виртуальных квазианалогах. Последние, на самом деле, реализуют численные методы решения, но представляют исследователю результаты в аналоговой форме.
    (Подробнее см. Федосов Б.Т. О методах описания линейных систем. Рудный, 2005
    http://model.exponenta.ru/bt/bt_001124.html )

Апостериорные методы позволяют ответить на вопрос о том, как поведет себя некоторая система, описываемая дифференциальным уравнением, если на нее будет подан известный заранее на всем временном интервале пробный сигнал, например ступенчатая функция или какой-нибудь другой. По поведению системы под пробным воздействием можно судить о том, как она будет вести себя и при других, такого же класса воздействиях.

Апостериорные методы не способны дать ответ на вопрос о поведении системы, если воздействие на нее поступает в режиме реального времени, т.е. когда не известно, как оно будет изменяться в дальнейшем. Такими возможностями обладают методы текущего времени.

2.1.2. Простейшие сигналы

Сигналы – это математические модели воздействий и реакций систем и объектов, т.е. это модели физических величин. Сигналы представляют собой функции времени и являются носителями информации.

    Воздействия и соответственно сигналы бывают:
  • - непрерывными и дискретными,
  • - детерминированными и случайными.

Простейшие сигналы сравнительно легко генерируются и используются в качестве пробных при исследовании объектов и систем управления.

С помощью простейших сигналов можно представить произвольный (сложный сигнал).

Простейшие сигналы:

  1. гармонический (синусоидальный);
  2. ступенчатый единичный сигнал (10(t) );
  3. дельта - функция Дирака (δ(t));
  4. степенная функция (tν).

2.1.2,а. Гармонический сигнал

Гармонический сигнал изменяется во времени по синусоидальному закону:

(2.3)

С помощью такого сигнала или набора (суммы) таких сигналов удобно моделировать периодические воздействия на системы, например вибрации, а также можно моделировать сигналы произвольного вида. Кроме того, синусоидальный сигнал используется в качестве пробного при исследовании установившегося режима работы САР.

Независимая переменная - время t меняется от минус до плюс бесконечности.

Гармонический сигнал (2.3) характеризуется тремя параметрами (числами):

  • - амплитудой Xm – максимальной величиной сигнала,
  • - круговой частотой ω [рад/сек] и
  • - начальной фазой φ [градусов].

Наряду с названными основными параметрами синусоидального сигнала используются и дополнительные параметры:

  • - f [Гц] = ω/2π - циклическая частота;
  • - Т [сек] = 1/f – период.

Рис. 2.1. Графическое изображение гармонических сигналов. Их величина изменяется с течением времени. Сигналы имеют период Т = 1 сек. Начальная фаза первого сигнала равна φ1 = 00, а второго φ2 = -360. Внизу показана вспомогательная шкала, позволяющая определить начальные фазы сигналов, имеющих период Т = 1 сек

На рис. 2.1 представлены графики зависимости от времени сигналов

(2.4)

Круговая частота этих сигналов равна ω = 2π рад/сек = 6.28 рад/сек. Их циклическая частота равна f = ω/2π = 1 Гц.

2.1.2,б. Ступенчатая единичная функция

Ступенчатая единичная функция моделирует подачу постоянного воздействия на объект и определяется следующим образом:

(2.5)

Другие названия ступенчатой единичной функции: функция Хевисайда, функция включения.

Ступенчатая функция используется в качестве пробного сигнала при оценке качества работы САР в переходном режиме. Произвольный сигнал может быть представлен бесконечной суммой ступенчатых функций.

Рис. 2.2. Осциллограммы ступенчатой единичной функции 10(t), а также ступенчатой единичной функции, умноженной на 0.8 и задержанной на 0.6 сек

2.1.2,в. Дельта - функция Дирака

Дельта – функция Дирака δ(t) это математическая модель короткого импульса:

(2.6)

Дельта - функция используется в качестве пробного сигнала при оценке качества работы САР в переходном режиме. Произвольный сигнал может быть представлен бесконечной суммой дельта - функций.

Дельта – функция может быть получена предельным переходом от импульса единичной площади, амплитуда которого обратно пропорциональна его длительности, при устремлении длительности импульса к нулю.

Рис. 2.3. Уменьшение длительности и пропорциональное увеличение амплитуды импульса единичной площади приближает его к дельта - функции Дирака

2.1.1,г. Степенная функция

Степенная функция используется для представления произвольных гладких сигналов рядом Тейлора, т.е. в виде суммы парабол различных степеней, а также в качестве пробного сигнала при оценке качества работы САР в установившемся режиме. Аналитически степенная функция записывается в виде:

(2.7)

Рис. 2.4. Графическое представление степенных функций различных порядков: нулевого - постоянная; первого – линейная функция, второго – парабола второго порядка и т.д. С увеличением порядка степенной функции все больше младших производных не равны нулю и функция с течением времени возрастает все быстрее и быстрее

2.2. Характеристики линейных объектов

Математическое описание системы или объекта регулирования в ТАУ состоит в описании причинно-следственной связи между воздействием на систему и ее реакцией на это воздействие. Для этого используются четыре вида взаимосвязанных функций, любая из которых полностью описывает свойства линейных систем:

  1. передаточная функция W(p), Ф(p);
  2. комплексный коэффициент передачи W(jω), Ф(jω) (ККП);
  3. переходная функция h(t);
  4. весовая или импульсная функция q(t).

2.2.1. Передаточная функция

Передаточная функция связывает изображение Y(p) выходного сигнала с изображением X(p) входного сигнала.

Применим к уравнению (2.2) справа и слева преобразование Лапласа:

(2.8)

Выразим изображение выходного сигнала Y(p) через изображение входного сигнала X(p):

(2.9)

(2.10)

Y(p) = W(p) · X(p)

Функция W(p), связывающая изображение Y(p) выходного сигнала с изображением X(p) входного сигнала называется передаточной функцией. Она имеет дробно-рациональный вид, т.е. вид дроби, в числителе и знаменателе которой полиномы по переменной p:

(2.11)

Знаменатель А(p) передаточной функции W(p) - характеристический полином линейной системы.

Характеристическое уравнение линейной системы:

(2.12)

A(p) = 0

Решения характеристического уравнения называют корнями pk характеристического полинома. Таких корней n, где n-степень характеристического полинома.

Рис. 2.5. Корни характеристического уравнения на комплексной плоскости

2.2.2. ККП – комплексный коэффициент передачи

В системе с нулевыми начальными условиями ККП получается из передаточной функции:

(2.13)

ККП связывает спектр выходного Y(jω) сигнала со спектром входного сигнала X(jω):

(2.14)

ККП может быть представлен в виде модуля и аргумента (показательная форма записи комплексной функции):

(2.15)

Физический смысл комплексного коэффициента передачи

Для синусоидального сигнала

(2.16)

спектр это его комплексная амплитуда:

(2.17)

Подставив в (2.14) получим

(2.18)

Отсюда, для амплитуд:

(2.19)

Ym = |W(jω)| Xm

Физический смысл модуля ККП |W(jω)| – это коэффициент усиления системой синусоидального сигнала. Величина этого усиления зависит от частоты усиливаемого сигнала.

Зависимость модуля ККП |W(jω)| от частоты называют амплитудно-частотной характеристикой (АЧХ). АЧХ показывает как зависит усиление линейной системы от частоты усиливаемого ей синусоидального сигнала.

Пусть φy – начальная фаза выходного сигнала. Тогда из (2.18)

(2.20)

φy = φw(ω) + φx(ω)

Как видно из (2.20) φw(ω) – показывает на какую величину по фазе задерживается синусоидальный сигнал, проходя линейную систему.

Зависимость аргумента ККП φw(ω) от частоты называют фазочастотной характеристикой (ФЧХ).

Рис. 2.6. АЧХ и ФЧХ некоторой линейной системы. Как видно, синусоидальные сигналы с частотами, меньшими 30 рад/сек, проходя систему практически не изменяются по амплитуде и задерживаются по фазе на величину, меньшую 1200. Сигналы с частотой, большей чем 60 рад/сек уменьшаются по амплитуде больше, чем в 10 раз, а по фазе задерживаются почти на 2700

Логарифмическая амплитудно-частотная характеристика
Логарифмическая фазочастотная характеристика

Это частотные характеристики, представленные в логарифмическом масштабе. Это позволяет графически показать частотные характеристики в больших частотном и амплитудном диапазонах.

Усиление откладывается в децибелах, вычисляемых по формуле:

(2.21)

L(ω)=20lg|W(ω)|, дБ

Рис. 2.7. Пример логарифмических амплитудно - частотной и фазо - частотной характеристик некоторой линейной системы. Частота меняется в 1000 раз - на три декады. Величина усиления меняется в миллион раз – на 120 дБ

Соотношение крат и децибел
Во сколько раз
1
2
4 = 2 x 2
10
100 = 10х10
1/2
1/100
1/1000000 		На сколько дБ
0
6
12 = 6+6
20
40 = 20+20
-6
-40
-120

Для логарифмического масштаба используются определения:

  • декада – изменение частоты в 10 раз;
  • октава – изменение частоты в 2 раза.

Годограф ККП или АФЧХ

Годограф ККП – это кривая на комплексной плоскости, которую пробегает конец вектора ККП при изменении частоты от 0 до ∞ .

Годограф ККП или АФЧХ (амплитудно - фазочастотная характеристика) позволяет на одном графике показать всю информацию, которая содержится на АЧХ и ФЧХ. АФЧХ изображается на комплексной плоскости

(2.22)

Рис. 2.8. Примеры годографов ККП некоторых линейных звеньев. С увеличением частоты вектор комплексного коэффициента передачи W(jω) поворачивается по часовой стрелке, уменьшаясь по величине. Расстояние от начала координат до точки годографа, соответствующей некоторой частоте, равно усилению звеном синусоидального сигнала этой частоты, а угол поворота φ вектора ККП это величина фазовой задержки на этой частоте, т.е. величины, прибавляемой звеном к начальной фазе синусоидального сигнала

По поведению годографа ККП разомкнутого контура САР (системы автоматического регулирования) можно судить о свойствах замкнутой САР, о ее работоспособности и пригодности для управления тем или иным объектом или процессом.

2.2.3. Переходная функция

Переходная функция – это реакция линейной системы на ступенчатое воздействие.

Переходная функция позволяет:

  1. оценить качество линейной САР при ее работе в переходном режиме. Если ступенька отрабатывается системой удовлетворительно, то тем лучше будут отслеживаться более плавные сигналы;
  2. определить реакцию системы на произвольное воздействие.

Рис. 2.9. Примеры переходных характеристик линейных систем: монотонная, колебательная и апериодическая. У хороших систем автоматического регулирования переходная функция находится на границе монотонного и апериодического режимов

2.2.4. Весовая или импульсная функция

Это реакция линейной системы на дельта-функцию Дирака. На практике дельта-функцию моделируют коротким импульсом, длительность которого много меньше времени отклика системы, а интеграл по времени равен единице.

Поскольку

(2.23)

(2.24)

(2.25)

(2.26)

Рис. 2.10. Весовые характеристики тех же линейных систем, переходные характеристики которых показаны на рис. 2.9

Весовая функция позволяет то же, что и переходная функция (см. п. 2.2.3).

Заключение

Воздействия на САР и реакции САР на эти воздействия описываются сигналами - функциями времени. Линейные системы автоматического регулирования описываются взаимосвязанными функциями: передаточной, комплексным коэффициентом передачи, переходной и весовой.

Зная, как изменяется во времени воздействие на систему и построив по дифференциальным уравнениям элементов и функциональной схеме модель САР в виде, например, передаточной функции, можно определить отклик САР на воздействие.

Изучая функции, которыми описывается САР, можно много узнать о ее свойствах.

Далее >>

К содержанию >>


2 Вопросы для самопроверки ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки по теме 2

Уравнения, модели и характеристики линейных систем

  • Вопрос 2.1
    Что такое ступенчатая единичная функция (функция включения, функция Хевисайда)?
  • Вопрос 2.2
    Что такое переходная функция линейной системы?
  • Вопрос 2.3
    Как узнать амплитуду выходного сигнала линейной системы, если на ее входе действует синусоидальный сигнал частоты ω = 14 рад/сек?
  • Вопрос 2.4
    Как узнать по ЛАЧХ и ЛФЧХ усиление линейной системы и ее фазовую задержку на некоторой частоте?
  • Вопрос 2.5
    Укажите основные характеристики линейной системы.

<< К темам вопросов

К главе 3 >>


ТАУ ЮНИТА 1 Лекция 3 Типовые звенья и идентификация САР

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

3. Типовые звенья и идентификация САР

3.1. Определение. Классификация звеньев

В ТАУ при моделировании систем применяют так называемые типовые звенья, которые приближенно соответствуют элементам реальных систем, точно и просто описываются математически.

Типовые звенья позволяют провести структурное моделирование системы управления путем замены функциональных элементов системы их структурными моделями. Свойства структурной модели системы исследуются математическими методами, а результаты исследований переносятся на исходную САР, позволяя судить о ее свойствах.

Классификация типовых линейных звеньев
    Классификация строится по возрастанию совокупности физических свойств, которыми обладают звенья, а также по возрастанию степени дифференциальных уравнений, которыми они описываются:
  1. простейшие звенья:
    • пропорциональное;
    • интегрирующее;
    • дифференцирующее;
  2. звенья I порядка:
    • апериодическое (инерционное);
    • форсирующее;
    • инерционно-дифференцирующее и др.;
  3. звенья II порядка:
    • колебательное и его частный случай
    • апериодическое звено II порядка;
  4. звено III порядка:
    • звено Вышнеградского - простейшее из звеньев с положительными коэффициентами характеристического полинома,способных терять устойчивость;
  5. звено запаздывания.

3.2. Простейшие звенья

3.2.1. Пропорциональное звено

Пропорциональное звено это такое звено, выходной сигнал y(t) которого пропорционален входному x(t):

(3.1)

y = k· x

Поэтому, передаточная функция пропорционального звена равна

(3.2)

W(p) = k

Таким образом, пропорциональное звено является безинерционным.

Рис. 3.1. Структурная схема пропорционального звена

Замечание: в статическом режиме многие отдельные звенья и даже целые системы автоматического регулирования (САР) можно промоделировать пропорциональным звеном. Коэффициент пропорциональности (усиления) звена может быть размерным, например, С0/В .

Пропорциональными звеньями моделируются усилители, редукторы, делители напряжения и т.п.

3.2.2. Интегрирующее звено

Интегрирующим звеном называется такое, выходной сигнал которого пропорционален интегралу по времени от входного сигнала:

(3.3)

где Т – постоянная времени интегратора, сек.

Как видно из (3.3), интегратор накапливает входной сигнал с течением времени. Постоянная времени интегратора T численно характеризует скорость этого накопления.

Рис. 3.2. Структурная схема интегрирующего звена

Примеры элементов систем, которые могут быть представлены интеграторами: емкости (электрическая и гидравлическая), вал некоторой машины или двигателя, угол поворота которого пропорционален интегралу от частоты вращения и др.

Передаточная функция интегратора:

(3.4)

где k = 1/Т – коэффициент усиления интегратора.

Переходная функция интегратора (реакция интегратора на ступенчатое единичное воздействие) в соответствии с определением (3.3) равна:

(3.5)

Рис. 3.3. Переходные функции интеграторов с разными постоянными времени. Переходная функция интегратора линейно растет с течением времени. Скорость роста обратно пропорциональна постоянной времени интегратора. Выходной сигнал интегратора достигает уровня ступенчатой функции за время, равное постоянной времени Т интегратора. Это позволяет определять постоянную времени интегратора по его экспериментально снятой характеристике

ЛАЧХ и ЛФЧХ интегратора, как следует из (3.4), выглядят следующим образом:

(3.6)

(3.7)

Рис. 3.4. Примеры ЛАЧХ и ЛФЧХ интеграторов с постоянными времени Т, равными 1 сек и 0.5 сек. ЛАЧХ интегратора – прямая линия, имеет наклон – 20 дБ/дек и пересекает ось частот на уровне 0 дБ на частоте 1/Т, обратной постоянной времени интегратора и равной коэффициенту усиления k интегратора. Значения ЛФЧХ не зависят от частоты: на любой частоте аргумент комплексного коэффициента передачи равен – 900

Таким образом, усиление интегратором синусоидального сигнала уменьшается с увеличением частоты, и сигнал любой частоты задерживается в интеграторе по фазе на 900.

3.3. Типовые звенья I порядка

3.3.1 апериодическое (инерционное) звено

Апериодическим звеном могут быть промоделированы не только элементы САР, обладающие инерционностью, но приближенно и некоторые простые САР целиком.

Физически апериодическое звено содержит один накапливающий энергию элемент, а также один или несколько элементов способных ее рассеивать.

Апериодическое это такое звено, которое описывается дифференциальным уравнением:

(3.8)

где: k – коэффициент усиления, который может быть размерным;
Т – постоянная времени апериодического звена, сек.

Рис.3.5. Представление апериодического звена на структурных схемах

Как видно из (3.8), такой сложное с физической точки зрения свойство объекта, как инерционность, пусть приближенно, но очень просто описывается математически: функцией с всего двумя параметрами (числами): k и T.

Из уравнения (3.8) следует, что передаточная функция апериодического звена равна:

(3.9)

Знаменатель передаточной функции (3.9) называется характеристическим полиномом апериодического звена:

(3.10)

Приравнивание характеристического полинома к нулю дает характеристическое уравнение апериодического звена:

(3.11)

pT + 1 = 0

Его решения называются корнями характеристического полинома. В данном случае корень один:

(3.12)

Этот корень и определяет инерционные свойства апериодического звена.

Комплексный коэффициент передачи апериодического звена следует из (3.9):

(3.13)

ЛАЧХ и ЛФЧХ апериодического звена получаются из (3.13):

(3.14)

Рис.3.6. ЛАЧХ и ЛФЧХ двух апериодических звеньев с коэффициентами усиления 22 (27 дБ) и 8 (18 дБ) и постоянными времени, равными 1 сек и 0.1 сек, и кусочно-линейно аппроксимация ЛАЧХ первого звена. Коэффициент усиления звена k определяет уровень ЛАЧХ в низкочастотной области, постоянная времени Т определяет частоту точки сопряжения линейных участков аппроксимации ЛАЧХ. На частоте 1/Т задержка по фазе апериодического звена составляет – 450. ЛФЧХ апериодического звена равна нулю на нулевой частоте, а с увеличением частоты стремится к -900

Переходная характеристика апериодического звена может быть получена обратным преобразованием Лапласа передаточной функции:

(3.15)

или непосредственным решением дифференциального уравнения (3.8)

Рис. 3.7. Примеры переходных характеристик апериодических звеньев. Коэффициент усиления звена определяет уровень, к которому стремится переходная характеристика с течением времени. Касательная, проведенная в начале координат к переходной характеристике, пересекает этот уровень в момент времени, равный постоянной времени апериодического звена Т. Эти свойства апериодического звена, а также то, что переходный процесс заканчивается приближенно за время, равное 3Т, позволяет определять параметры звена (коэффициент усиления и постоянную времени) по его экспериментальной переходной характеристике

Как видно, апериодическое звено не сразу, а постепенно реагирует на ступенчатое воздействие, в этом и проявляется его инерционность, которая численно может характеризоваться величиной постоянной времени, поскольку переходный процесс заканчивается примерно за 3Т. За время 3Т переходная характеристика достигает 95% уровня, к которому она стремиться при стремлении времени к бесконечности.

3.3.2 форсирующее звено (ускоряющее звено)

В чистом виде, автономно форсирующее звено в природе не существует. Автономно оно физически не реализуемо, но может быть включено как элемент в модели более сложных звеньев и широко применяется в практике построения систем управления.

Форсирующее звено при правильно подобранных параметрах стабилизирует систему и одновременно повышает ее быстродействие.

Рис. 3.8. Представление на структурной схеме форсирующего звена

Форсирующее звено – это такое, у которого передаточная функция равна:

(3.16)

Как видно из (3.16), передаточная функция обратна передаточной функции инерционного звена, поэтому включение форсирующего звена последовательно с инерционным уменьшает их совокупную инерционность.

Пример: ПИ-регулятор устройство, задающее закон регулирования, часто используемый на практике. Его передаточная функция содержит форсирующий множитель:

(3.17)

3.3.3 инерционно - дифференцирующее звено

Такие звенья применяются в так называемых гибких обратных связях, повышая при правильно подобранных параметрах, быстродействие и устойчивость системы

Инерционно - дифференцирующее звено это такое, передаточная функция которого равна:

(3.18)

Примечание: теоретически можно рассматривать и звенья с отрицательными коэффициентами характеристического полинома, но на практике их не следует применять в виду их неустойчивости.

3.4. Колебательное звено

Это звено может возвращаться в исходное состояние по окончанию воздействия на него колебательным или монотонным образом в зависимости от его параметров.

Физически колебательное звено содержит два элемента, способных накапливать энергию разного вида (кинетическую и потенциальную, электрическую и магнитную), а также один или несколько элементов способных рассеивать энергию.

Рис. 3.9. Представление колебательного звена на структурной схеме

Колебательное звено это такое звено, дифференциальное уравнение которого имеет вид:

(3.19)

Звено характеризуется тремя параметрами:

  • Т – постоянная времени, сек;
  • k – коэффициент усиления, может быть размерным;
  • δ - декремент затухания, характеризующий скорость затухания свободных колебаний звена.

  • Если δ < 1, звено называется колебательным.
  • Если δ > 1, звено называется также и апериодическим звеном II порядка.

Как видно из дифференциального уравнения, передаточная функция колебательного звена имеет вид:

(3.20)

Отсюда, характеристическое уравнение имеет вид:

(3.21)

При решении данного уравнения могут быть два случая:

  • а) р1 и р2 – действительные корни (апериодическое звено II порядка, при этом δ > 1);
  • б) р1,2 = -σ ± jω - комплексно сопряженные корни.

Рис. 3.10 (анимация, 8 кадров)

Рис. 3.10 (анимация, 8 кадров - для запуска, если не работает, щелкнуть по кнопке "Обновить"). Движение корней на комплексной плоскости при изменении декремента затухания δ колебательного звена от бесконечности до нуля. С уменьшением δ, но при δ > 1, корни двигаются навстречу друг другу по действительной оси и совпадают при δ = 1. Долее, при уменьшении δ корни расходятся по окружности радиуса 1/Т и стремятся к мнимой оси при δ → 0

Очень красиво и интересно! Напоминает движение шаров в бильярде. Конечно, с тем отличием, что независимой переменной здесь является не время, а декремент затухания δ.

Комплексный коэффициент передачи колебательного звена следует из (3.20):

(3.22)

ЛАЧХ и ЛФЧХ колебательного звена получаются из (3.22)

(3.23)

Рис. 3.11. ЛАЧХ и ЛФЧХ колебательного звена. На низких частотах ЛАЧХ любого колебательного звена проходит на уровне 20lg(k), а на высоких частотах ЛАЧХ имеет наклон –40 дБ/дек. Линии аппроксимации, проведенные их области нижних частот и из области верхних частот, пересекаются на частоте 1/Т, обратной постоянной времени Т звена. ЛАЧХ звена с декрементом затухания δ = 0.5 практически совпадает с линиями аппроксимации. При δ < 0.5 ЛАЧХ имеет пик, высота которого A = 20lg(1/2δ) позволяет определить величину декремента затухания δ. Эта формула работает и для δ > 0.5, когда ЛАЧХ проходит ниже линий аппроксимации. ЛФЧХ всех колебательных звеньев на нижних частотах стремятся к нулю, на верхних частотах они стремятся к -1800, а на частоте -1/Т, все они имеют значение - 900. Крутизна ЛФЧХ увеличивается с уменьшением декремента затухания δ

Переменные: k, T, δ определяют поведение ЛАЧХ и ЛФЧХ и, в свою очередь, могут быть определены по этим характеристикам (см. рис. 3.11).

При малом затухании ( δ < 0.5) – резонанс.

Для апериодического звена II порядка, когда δ > 1 может быть использована и другая форма представления передаточной функции:

(3.24)

Параметры знаменателя (3.24) связаны условием: Т2 > 4T1 (это выполняется при δ > 1)

Из сравнения (3.24) и (3.22) переход от одних параметров к другим осуществляется по формулам:

(3.25)

Переходная характеристика колебательного звена

Рис. 3.12. Альтернативное представление линейного звена, в частности колебательного, на структурной схеме

Рис. 3.13. Переходные функции колебательных звеньев. С течением времени значения характеристик стремятся к величине коэффициентов усиления звеньев. При δ > 1 колебательность переходной функции исчезает, функция становится монотонной. Постоянная времени Т колебательного звена не равна периоду колебаний Ткол: , при δ < 0.5 период затухающих колебаний равен примерно Ткол ≈ 2 π Т

По колебательной (δ < 0.5) переходной характеристике колебательного звена можно приближенно оценить его параметры:

  • - уровень успокоения колебаний равен коэффициенту усиления звена;
  • - постоянная времени равна Т ≈ Ткол/2π;
  • - декремент затухания δ ≈ 3Т/Тпер

Рис. 3.14. Переходная функция колебательного звена позволяет оценить его параметры

Длительность переходного процесса Тпер колебательного звена при δ < 0.5 равна 3Т/δ, при δ > 1 она составляет 6δТ. При δ = 0.707 длительность переходного процесса минимальна и составляет 2.3·Т.

Рис.3.15 . Зависимость длительности и вида переходного процесса колебательного звена от его декремента затухания и постоянной времени

Отметим, что большинство устойчивых систем управления, может быть вполне удовлетворительно промоделировано колебательным звеном, а переходная характеристика этой модели, позволяет численно оценить качество системы управления.

3.5. Звено запаздывания

Звено запаздывания задерживает выходной сигнал по времени относительно входного на время τз:

(3.28)

Рис. 3.16. Обозначение звена запаздывания на структурной схеме

Свойства звена запаздывания проявляются в протяженных транспортных и информационных системах.

Рис. 3.17. Песок ссыпается с транспортера через некоторое время после того, как он попадает на транспортер из бункера

Рис. 3.18. Если рассматривать скорость поступления песка из бункера на ленту транспортера и выгрузки его с ленты как входной и выходной сигналы, то выходной оказывается задержанным на время τз = 20 сек по сравнению со входным. В условный нулевой момент бункер открывают, и песок начинает поступать на ленту (синяя линия). Песок, попавший на ленту 20 сек назад, высыпается с нее (красная линия)

Применим к уравнению (3.28) преобразование Лапласа. Получим:

(3.29)

Отсюда, передаточная функция звена запаздывания равна:

(3.30)

Отсюда, комплексный коэффициент передачи звена запаздывания равен:

(3.31)

Рис. 3.19. ЛАЧХ и ЛФЧХ звена запаздывания (красные линии). Усиление звена на всех частотах равно 1 (0 дБ). ЛФЧХ с увеличением частоты неограниченно убывает. Для сравнения приведены ЛАЧХ и ЛФЧХ апериодического звена (коричневые линии) с постоянной времени, равной времени задержки сигнала в звене запаздывания. Как видно, в области нижних частот, вплоть до частоты в 1 рад/сек (величины, обратно пропорциональной постоянной времени апериодического звена) характеристики совпадают. Это значит, что для медленно изменяющихся сигналов звено запаздывания может быть заменено апериодическим звеном

Рис. 3.20. АЧХ и ФЧХ звена запаздывания (красные линии). Усиление звена равно 1 на всех частотах, задержка по фазе растет пропорционально частоте. Для сравнения приведены АЧХ и ФЧХ апериодического звена (коричневые линии)

3.6. Идентификация линейных САР и их элементов

Идентификация САР или ее элемента, например объекта управления, это подбор типового звена или совокупности нескольких звеньев, свойства которых достаточно близки к свойствам моделируемого элемента или САР в целом, и определение их параметров.

Идентификация может быть осуществлена многими способами, наиболее простые из которых это определение типа и параметров модели по переходным или по частотным характеристикам моделируемого элемента, снятым экспериментально.

Наиболее значимым элементом САР является объект управления. Переходную характеристику объекта управления в технической практике часто называют разгонной характеристикой, что подчеркивает смысл отражаемого этой характеристикой процесса: изменение выходной, управляемой величины, т.е. разгон объекта, вследствие ступенчатого приращения его управляющей величины.

Пример. Построить модель объекта регулирования по его переходной характеристике:

Рис. 3.21. Экспериментально снятая разгонная характеристика объекта управления

Как видно на рис. 3.21, объект имеет запаздывание, а инерционная его часть может быть промоделирована апериодическим звеном первого или второго порядка. Модель второго порядка более точно аппроксимирует начальный участок возрастания переходной характеристики, поэтому построим ее:

Рис. 3.22 (анимация 5 кадров). Определение параметров модели объекта второго порядка. Для просмотра отдельного кадра следует щелкнуть по кнопке "Остановить" браузера (вверху окна, в котором Вы читаете этот текст). Для запуска анимации с начала нужно щелкнуть по кнопке "Обновить" браузера или просто по рисунку

По рис. 3.22 видно, что передаточная функция модели должна иметь вид:

(3.32)

поскольку 3Т1 = 0.4 сек и 3Т2 = 4.8 сек, то Т1 = 0.12 сек и Т2 = 1.6 сек.

Величина 3Т1 определяется от момента начала роста разгонной характеристики до момента ее совпадения с касательной к разгонной характеристике в средней ее части. Время запаздывания τз и большая постоянная времени Т2 инерционной части в данном случае совпали случайно.

Сравнение исходной разгонной характеристики и ее аппроксимации, полученной по модели (3.32) приведено на рис. 3.23:

Рис. 3.23. Исходная разгонная характеристика (коричневая линия) и ее аппроксимации

Как видно на рис. 3.23, предварительная аппроксимация (синяя линия) довольно близка к исходной коричневой кривой, хотя в полученной модели постоянные времени Т1 и Т2 несколько занижены. Их значения могут быть подкорректированы методом проб и ошибок (красная кривая).

Заключение

Реальные САР можно мысленно разделить на отдельные физические компоненты так, что взаимодействие между ними будет однонаправленным: последующие элементы практически не будут влиять на работу предыдущих. Такие элементы могут быть промоделированы типовыми звеньями. Объединив типовые звенья должным образом, можно получить структурно-алгоритмическую схему, модель САР.

Для определения того, каким типовым звеном следует представить тот или иной элемент, следует составить для него дифференциальное уравнение, которое и определит тип звена. Для многих стандартных элементов САР и объектов дифференциальные уравнения уже давно составлены. Поэтому для решения конкретной задачи достаточно выбрать в литературе тип звена и определить его параметры: коэффициент усиления и постоянные времени.

Другой способ идентификации, т.е. подбора типового звена в качестве модели для некоторого элемента системы, состоит в сравнении экспериментально полученных характеристик элемента, например, переходной функции или частотных характеристик, с характеристиками типовых звеньев, выбором наиболее подходящего и определением его параметров.

Звено Вышнеградского, наиболее простое из звеньв, способных терять устойчивость, будет рассмотрено в главе 5, посвященной устойчивости звеньев и систем.

Далее >>

К содержанию >>


3 Вопросы для самопроверки ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки по теме 3

Типовые звенья и идентификация САР

  • Вопрос 3.1
    Укажите передаточную функцию интегратора, его переходную функцию, ЛАЧХ и ЛФЧХ
  • Вопрос 3.2
    Укажите передаточную функцию апериодического звена, его переходную функцию, ЛАЧХ и ЛФЧХ
  • Вопрос 3.3
    Укажите передаточную функцию колебательного звена, его переходную функцию
  • Вопрос 3.4
    Укажите ЛАЧХ и ЛФЧХ колебательного звена
  • Вопрос 3.5
    Укажите передаточную функцию звена запаздывания и его переходную функцию

<< К темам вопросов

К главе 4 >>


ТАУ ЮНИТА 1 Лекция 4 Соединение звеньев и преобразование структурных схем

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

4. Соединение звеньев и преобразование структурных схем
Типовая схема САР

Используя теоремы о соединении звеньев, можно привести сложную схему, состоящую из звеньев с простыми передаточными функциями, к простой схеме, состоящей из звена или звеньев со сложными передаточными функциями. Такое преобразование увеличивает наглядность модели, упрощает, унифицирует ее анализ.

4.1. Теоремы о соединении звеньев

4.1.1. Последовательное соединение

При таком соединении выходной сигнал предыдущего звена является входным сигналом последующего звена:

Рис. 4.1. Последовательное соединение звеньев

Теорема 1. Передаточная функция последовательного соединения звеньев равна произведению передаточных функций отдельных звеньев:

(4.1)

W(p)=W1(p)·W2(p)

Частным случаем линейного звена является идеальный усилитель (пропорциональное звено) с передаточной функцией W(p) = k. Общее усиление последовательного соединения усилителей равно произведению коэффициентов усиления отдельных звеньев Wn(p) = k1 · k2 ... kn.

Следствие: ЛАЧХ последовательного соединения звеньев равна сумме ЛАЧХ отдельных звеньев:

(4.2)

L(ω) = L1(ω) + L2(ω) + ... + Ln(ω)

4.1.2. Параллельное согласное соединение

При таком соединении входной сигнал всех звеньев один и тот же, а выходной равен сумме выходных сигналов всех звеньев.

Рис. 4.2. Параллельное согласное соединение двух звеньев

Теорема 2. Передаточная функция параллельного согласного соединения звеньев равна сумме передаточных функций отдельных звеньев:

(4.3)

W(p) = W1(p) + W2(p)

Следствие. Переходная функция параллельного согласного соединения звеньев равна сумме переходных функций отдельных звеньев:

(4.4)

h(t) = h1(t) + h2(t) +...+ hn(t)

4.1.3. Параллельное встречное соединение
(системы с обратной связью)

При таком способе соединения звенья соединены следующим образом:

Рис. 4.3. Параллельное встречное соединение звеньев. Выходной сигнал, пройдя звено обратной связи, вычитается (отрицательная обратная связь ООС) из входного сигнала и подается на звено прямой связи

Теорема 3. Передаточная функция параллельного встречного соединения звеньев равна:

(4.5)

где: W1(p) – передаточная функция звена прямой связи;

W2(p) – передаточная функция звена обратной связи.

4.2. Преобразование схем с использованием переносов ветвлений и сумматоров через звено

Бывают случаи, когда соединение звеньев сложное: и не параллельное, и не последовательное. Такое может быть в многоконтурных схемах с перекрещивающимися связями. В этом случае, для упрощения схем, переносят через звенья узлы ветвления или сумматоры.

4.2.1. Перенос ветвления влево

Узел ветвления из соображений реализуемости результирующей схемы целесообразно переносить через звено влево:

Рис. 4.4. Эквивалентные схемы. Ветвление перенесено влево через звено W1(p)

Для сохранения эквивалентности схем, при переносе ветвления влево следует добавить в схему блок с передаточной функцией W1(p). Тогда в обеих схемах передаточные функции по каналу х → y1 будет равны:

(4.6)

Y1(p)= W1(p) · X(p))

4.2.2. Перенос сумматора вправо

Сумматор из соображений реализуемости результирующей схемы целесообразно переносить вправо:

Рис. 4.5. Эквивалентные схемы. Сумматор перенесен вправо через звено W2(p)

Для сохранения эквивалентности схем, при переносе сумматора вправо следует добавить в схему блок с передаточной функцией W2(p). Тогда в обеих схемах выходные сигналы будут одинаковыми:

(4.7)

Y(p)=X(p) · W1(p) · W2(p) +X2(p) · W2(p)

4.3. Типовая одноконтурная САР

Для упрощения и унификации анализа, сложные схемы САР приводят к типовому виду. Все элементы контура исходной САР, кроме сумматора и объекта управления сворачивают в одно звено, которое условно называют регулятором. Обратная связь – единичная отрицательная. Возмущение приводится к входу объекта управления. Схема приобретает вид:

Рис. 4.6. Типовой вид структурная схемы одноконтурной САР

4.3.1. Передаточная функция W(p) разомкнутого контура

Эта вспомогательная функция содержит всю основную информацию о свойствах замкнутой системы, в том числе о степени устойчивости и показателях качества: точности и быстродействия.

Рис.4.7. Разомкнутый контур типовой САР (обратная связь разорвана)

Из сравнения рис.4.6 и рис.4.7 видно, что передаточная функция разомкнутого контура равна произведению передаточных функций регулятора и объекта управления, поскольку в контуре имеется лишь два звена и включены они последовательно:

(4.8)

W(p) = Wp(p)· Wo(p)

4.3.2. Передаточная функция Фз(p) замкнутой САР по каналу управления

Эта функция описывает основное назначение САР: слежение. Выходной сигнал y(t) САР должен повторять задание x(t) с требуемой точностью.

Рис. 4.8. Типовой вид структурной схемы замкнутой САР. Обратная связь жесткая, единичная

Передаточная функция замкнутой САР рис. 4.8 по каналу управления (по заданию), как следует из теоремы 3, равна:

(4.9)

Используя эту функцию, можно вычислить выходной сигнал типовой САР, см. (2.10), например такой, какой показан на рис. 4.9.

Рис. 4.9. Реакция типовой САР на ступенчатое единичное воздействие. Управляемая величина с течением времени стремится к единице - значению входного сигнала. САР осуществляет слежение

4.3.3. Передаточная функция Фез(p) замкнутой САР по ошибке, обусловленной заданием

Точность слежения, т.е. точность поддержания выходной величины объекта равной заданию, является одной из важнейших характеристик САР, определяющих ее качество.

Выходной сигнал сумматора типовой САР представляет собой ошибку регулирования e(t), которая может меняться с течением времени.

Структурную схему можно изменить, сделав выходом выход сумматора. При этом все элементы контура окажутся в звене обратной связи:

Рис. 4.10. Структурная схема типовой САР, приведенная к виду, в котором выходным сигналом является ошибка регулирования е = х - у. С течением времени ошибка регулирования стремится к нулю вследствие работы САР

Передаточная функция замкнутой САР по ошибке, обусловленной заданием, как следует из теоремы 3, равна:

(4.10)

Рис. 4. 11. Характерный вид амплитудно – частотных характеристик типовой САР по заданию, а также по ошибке, обусловленной заданием. Как видно, на нижних частотах САР полезна (|Фз(ω)| ≈ 1, т.е. относительно медленно изменяющиеся сигналы САР отслеживает), на верхних – бесполезна (|Фз(ω)| ≈ 0 и выходной сигнал не повторяет быстро изменяющееся задание), а на средних может быть даже вредна. Отметим, что ошибка отслеживания гармонического сигнала начинает довольно быстро возрастать уже на низких частотах

Для правильной эксплуатации САР, необходимо чтобы управляющие воздействия изменялись достаточно медленно, т.е. ширина их спектра не превышала бы частоту ω0, на рис. 4.11 равную примерно 2 - 3 рад/сек.

Рис. 4. 12. Одновременная индикация на осциллографе управляемой величины (красная линия) и ошибки регулирования (синяя линия) в зависимости от времени при задающем воздействии в виде ступенчатой функции и возмущении, равном нулю. Сумма ошибки и управляемой величины в любой момент времени равна единице, т.е. величине входного сигнала

4.3.4. Передаточная функция Фв(p) замкнутой САР по возмущению

В типовой САР совокупность возмущающих воздействий на объект управления, препятствующих его правильному поведению, приводится ко входу объекта:

Рис. 4.13. Схема типовой САР с указанием места аддитивного приложения возмущения, а также схема этой САР, где задание равно нулю, а входным сигналом является возмущение

Передаточная функция замкнутой САР по возмущению с учетом второй схемы рис. 4.13 и теоремы 3, равна:

(4.11)

Рис. 4.14. Действие САР компенсирует влияние единичного ступенчатого возмущения на объект управления. Ошибка регулирования e(t) (синяя кривая), вызванная возмущением, не превышает 0.024 (2.4 %), САР хорошо стабилизирует объект

Зная передаточные функции, рассмотренные выше, можно вычислить, как задание и возмущение влияют на управляемую величину. Кроме того, эти передаточные функции, прежде всего W(p) и Фз(p) позволяют прямо и косвенно оценить качество САР.

4.3.5. Уравнения динамики и статики типовой САР

Эти уравнения описывают реакцию САР на одновременное действие и задания, и возмущения. Описание основывается на реализации принципа суперпозиции, справедливого для линейных систем. Уравнение динамики типовой САР в операторной форме (или, что то же - Лапласово изображение дифференциального уравнения САР) имеет вид:

(4.12)

для выходного сигнала САР и

(4.13)

для ошибки регулирования.

Для статической системы в уравнениях (4.12), (4.13) следует принять p = 0 и при переходе к оригиналам они примут вид уравнений статики:

(4.14)

Как видно из (4.14) в статике, т.е. в установившемся режиме при действии на входе постоянных величин, статическая система работает тем лучше, чем больше коэффициент усиления контура k.

Примечание. Забегая вперед, отметим, что, улучшая качество САР в установившемся режиме, увеличение коэффициента усиления контура улучшает качество САР в переходном режиме только до определенных пор (см. Юнита 2, глава 5). Начиная с некоторой величины коэффициента усиления, его увеличение не только не улучшает качество САР, но напротив, приближает ее к т.н. границе устойчивости, когда качество САР становится все хуже, а, начиная с некоторого значения коэффициента усиления контура, САР и вовсе теряет устойчивость, а с ней и работоспособность.

Рис.4.15. Совокупное воздействие на САР задания и возмущения в виде ступенчатых функций. САР осуществляет слежение за заданием и стабилизацию, т.е. компенсирует влияние возмущения на управляемую величину

На рис. 4.15 видно, что в нулевой момент времени задание меняется с нулевого на единичное и САР за 4 сек приводит управляемую величину (выходную величину объекта управления) к установившемуся значению по уровню равному заданию. Тем самым подтверждается, что САР осуществляет слежение за заданием. Через 10 сек после подачи ступенчатого задания, на САР поступает ступенчатое возмущение величиной 10 Н·м. Это приводит к появлению ошибки регулирования, которую САР за две секунды компенсирует. Следовательно, САР осуществляет стабилизацию.

Для астатической системы уравнения статики вырождаются в простейшие, поскольку Wастат(0) = ∞:

(4.15)

Как видно, астатическая система в статике идеально следит и идеально стабилизирует. Это обусловлено наличием по крайней мере одного интегратора в контуре САР (см. юнита 2 Анализ линейных систем автоматического регулирования, глава 6).

4.4. Многомерные системы управления

Такие системы имеют несколько входов и несколько выходов и часто встречаются на практике:

Рис. 4.16. Структурная схема системы управления с двумя входами и с двумя выходами

Описание многомерной системы управления методом вход-выход

Поскольку система предполагается линейной по каждому входу, то работает принцип суперпозиции. Значит, выходной сигнал на каждом выходе может быть получен суммированием отдельных сигналов, вызываемых отдельными входными сигналами. Это позволяет составить линейную систему уравнений, полностью описывающую САР:

(4.16)

Y1(p) = W11(p)·X1(p) + W12(p)·X2
Y2(p) = W21(p)·X1(p) + W22(p)·X2

Система уравнений (4.16) позволяет построить эквивалентную структурную схему многомерной САР:

Рис. 4.17. Эквивалентная структурная схема многомерной САР. Каждый входной сигнал вносит свой вклад в каждый выходной сигнал

Заключение

Математическое описание САР позволяет исследовать ее свойства анализируя ее модель.

К вопросам по теме >>

К содержанию >>

К файлу материалов >>


4 Вопросы для самопроверки ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки по теме 4

Соединение звеньев и преобразование структурных схем. Типовая схема САР

  • Вопрос 4.1
    Указать формулы передаточной функции, ЛАЧХ и ЛФЧХ последовательного соединения двух звеньев
  • Вопрос 4.2
    Указать формулы передаточной и переходной функций параллельного согласного соединения двух звеньев
  • Вопрос 4.3
    Указать формулы передаточной функции параллельного встречного соединения двух звеньев
  • Вопрос 4.4
    Определить моменты времени, в которые на САР поступает ступенчатое изменение задания и на объект управления поступает ступенчатое изменение возмущения
  • Вопрос 4.5
    Даны экспериментально снятые ЛАЧХ и ЛФЧХ некоторого объекта.
    Определить тип звеньев модели объекта, составленной из последовательного соединения типовых звеньев, а также передаточную функцию модели.

<< К темам вопросов


ТАУ ЮНИТА 1 Файл материалов

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Файл материалов
(справочные материалы)

В разделе приведены сведения о моделирующих программных комплексах Vissim и "МВТУ", использование которых при решении задач ТАУ позволяет в значительной мере исключить кропотливый труд по расчету характеристик проектируемых систем, отказаться от применения традиционных методов расчета, сосредоточив внимание на изучении свойств проектируемых и исследуемых систем.
Далее приведены основные формулы, описывающие типовые звенья и их соединение.

  • 1. Краткие сведения о структурно-объектном моделировании и о программном комплексе VisSim
  • 2. Краткие сведения о программном комплексе "МВТУ"
  • 3. Основные формулы
    • 3.1. Характеристики типовых звеньев
    • 3. 2. Теоремы о соединении звеньев

1. Краткие сведения о структурно-объектном моделировании и о программном комплексе VisSim

  • 1.1. Назначение программы VisSim
  • 1.2. Графический интерфейс VisSim
  • 1.3. Принципы построения моделей в среде VisSim
  • 1.4. Основные блоки VisSim
  • 1.5. Принципы управления моделью и получения результатов моделирования
  • 1.6. Понятие о принципах функционирования программы VisSim
  • 1.7. Версии VisSim

Понятие "модель" весьма широкое и многозначное. Можно утверждать, что человек, часто не думая об этом, в жизни все время создает и использует всевозможные модели: окружающего пространства, поведения других людей, физических и технических объектов и т.д., с тем, чтобы получить практическую пользу. Можно сказать, что отображение реальности сознанием человека является в той или иной степени моделированием. Например, переходя дорогу, мы моделируем движение приближающейся машины, чтобы предсказать, успеем ли безопасно перейти, и выбрать правильное решение.

В науке и технике модели могут быть:

  • физическими (масштабными и аналоговыми),
  • математическими (аналитическими),
  • виртуальными (воображаемыми, реализуемыми на компьютерах) и др.

Моделирование технических объектов и систем проводится для того, чтобы определить свойства и характеристики проектируемых систем еще до их изготовления и при необходимости скорректировать, уточнить их структуру и параметры. Это позволяет получить проект работоспособной системы, которую не придется существенно дорабатывать тогда, когда она будет изготовлена. Таким образом, моделирование сокращает и удешевляет процесс проектирования и реализации систем и объектов.

Кроме того, на модели системы можно проверить ее поведение в таких условиях и режимах, для которых система не предназначена, с тем, чтобы знать, как она себя поведет и к каким последствиям это приведет. Очевидно, что такие эксперименты на реальной системе могут быть не только дороги, но и небезопасны, в то время как моделирование позволяет получить нужную информацию о процессе или системе без лишних затрат и, главное, без негативных последствий.

1.1. Назначение программы VisSim

Программа VisSim предназначена для построения, исследования и оптимизации виртуальных моделей физических и технических объектов, в том числе и систем управления. VisSim это аббревиатура выражения Visual Simulator – визуальная, воспринимаемая зрением, среда и средство моделирования.

Программа VisSim, разработана и развивается компанией Visual Solutions (USA) [1]. Эта программа – мощное, удобное в использовании, компактное и эффективное средство моделирования физических и технических объектов, систем и их элементов.

Программа предоставляет человеку развитой графический интерфейс, используя который, исследователь создает модель из виртуальных элементов с некоторой степенью условности так же, как если бы он строил реальную систему из настоящих элементов. Это позволяет создавать, а затем исследовать и оптимизировать модели систем широкого диапазона сложности.

При описании и последующем построении модели в среде VisSim нет необходимости записывать и решать дифференциальные уравнения, программа это сделает сама по предложенной ей исследователем структуре системы и параметрам ее элементов. Результаты решения выводятся в наглядной графической форме. Поэтому программой могут пользоваться и те, кто не имеет глубоких познаний в математике и программировании.

При использовании VisSim 'а не требуется владеть программированием на языках высокого уровня или ассемблере. В то же время, специалисты, владеющие программированием, могут создавать собственные блоки, дополняя ими богатую библиотеку стандартных блоков VisSim'а.

Моделирование систем управления это далеко не весь круг задач, которые можно решать в VisSim. Например, в этой программе при желании можно решать дифференциальные уравнения и VisSim делает это значительно эффективнее и быстрее, чем известная программа математической направленности MathCAD. При соизмеримой и более высокой производительности, чем у программы Simulink, входящей в солидный программный пакет MathLab, VisSim занимает в сотни раз меньше места на жестком диске и в оперативной памяти.

VisSim позволяет также решать задачки по физике, начиная с уровня школьных и кончая серьезными физическими экспериментами на виртуальных лабораторных стендах.

Рис. 1.1 (анимация 29 кадров). Воспроизведение анимации, созданной в программе VisSim для иллюстрации решения задачи о полете пушечного ядра с учетом сопротивления воздуха. Траектория полета ядра подчиняется соотвествующим уравнениям, которые решает VisSim. Из графиков траекторий видно, что существенное изменение угла наклона ствола пушки с 20° до 30° приводит к незначительному изменению дальности полета снаряда.

Если изображение не меняется, щелкните левой кнопкой мыши по рисунку

Решение задачи о полете пушечного ядра с учетом сопротивления воздуха осуществляется моделью, созданной в VisSim'е:

Рис. 1.2. Наполнение составного блока Calculation of a trajectory (рис. 1.1), осуществляющего вычисление траектории полета ядра и отображение ее и других переменных величин. VisSim позволяет всесторонне изучить поведение модели.

Российским аналогом программы VisSim является программный комплекс "МВТУ" [2].

1.2. Графический интерфейс VisSim

Интерфейс программы это совокупность средств, позволяющих человеку общаться с ней:

  • вводить и получать данные,
  • контролировать ход выполнения компьютером программы,
  • подавать управляющие воздействия и наблюдать реакцию на них программы и т.п.

Программа VisSim предоставляет исследователю графический интерфейс, позволяющий основную часть работы по созданию модели выполнить с помощью мыши, а параметры элементов ввести с клавиатуры. Интерфейс VisSim состоит из главного окна, имеющего меню и ряд кнопок управления, воспринимающих щелчки копок мыши, и т.н. рабочего пространства, в котором строится и корректируется модель, наблюдаются результаты ее работы (рис.1.3).

С точки зрения исследователя интерфейс программы VisSim представляет собой интерактивный виртуальный лабораторный стенд, обеспечивающий построение моделей из отдельных блоков, запуск процесса моделирования, управление им и контроль результатов.

Главное окно VisSim, с примером простой диаграммы имеет вид рис.1.3.

Рис.1.3. Главное окно программы VisSim и ее рабочее пространство с примером простой VisSim-диаграммы (модели). На рабочее пространство вынесены виртуальные блоки: генератор и осциллограф, а также надписи. При запуске процесса моделирования (щелчком по кнопке с зеленым треугольником [image] Пуск - Go ), на осциллографе изображается сигнал, вырабатываемый генератором, в данном случае - синусоида. Амплитуду, частоту и начальную фазу сигнала генератора исследователь может менять, и при новом запуске моделирования эти изменения будут приводить к соответствующему изменению графика на экране осциллографа. В верхней части окна отображается название диаграммы

Диаграммой в VisSim'е называется совокупность связанных, а также автономных блоков и надписей, помещенных на рабочее пространство и способных в известном смысле функционировать при запуске процесса моделирования. Диаграмма может быть сохранена в виде отдельного файла и, при необходимости, открыта вновь.

Модель VisSim’а это часть диаграммы, содержащая виртуальный аналог реальной или проектируемой системы. Диаграмма может содержать несколько моделей.

К модели VisSim'а в принципе могут быть подключены, с помощью дополнительных компьютерных плат, и внешние физические устройства, которыми модель системы, построенная в VisSim’е, сможет управлять. Таким образом, объектами управления модели системы автоматического управления, построенной в VisSim, могут быть не только виртуальные, но и реальные устройства.

1.3. Принципы построения моделей в среде VisSim

Исходными данными для построения модели в VisSim’е являются структурно-функциональная схема моделируемой системы, процесса или объекта и описывающие их дифференциально-алгебраические уравнения. Вместо таких уравнений могут быть заданы операторы или функции, характеризующие отдельные элементы моделируемой системы, например, передаточнные функции для линейных элементов и статические характеристики для нелинейных элементов.

Рис.1.4. Исходная функциональная схема САР частоты вращения вала двигателя постоянного тока и ее структурно-алгоритмическая модель

Реальные системы и объекты состоят из отдельных, связанных и взаимодействующих друг с другом элементов. И для всей системы в целом, и для отдельных ее, должным образом выбранных элементов, можно указать место приложения воздействия, которое можно назвать входом, и место их реакции (отклика) на входное воздействие, называемое выходом. И воздействие, и реакция это некоторые физические величины, являющиеся функциями времени.

Модели систем и объектов в программе VisSim строятся из отдельных элементов – т.н. блоков. Блок это виртуальный аналог физического элемента реальной системы. «Виртуальный» в данном контексте значит воображаемый, физически не существующий, реализуемый программно, но с точки зрения человека, работающего с моделирующей программой, блок воспринимается зрением, он видим на рабочем пространстве VisSim. Термин «аналог» предполагает, что блок функционирует, он подчиняется тем же самым уравнениям, что и реальный, моделируемый элемент системы.

Виртуальные блоки VisSim’а могут иметь или вход, на который может быть подан выходной сигнал другого блока, или выход, виртуальный сигнал с которого может быть подан на вход другого блока. Наконец, блоки могут иметь и вход, и выход одновременно. Взаимодействие между блоками отображается т.н. линиями связи, указывающими направление передачи воздействий (сигналов) от одного блока к другому.

Взаимодействие между блоками моделируется сигналами – функциями времени, передаваемыми между блоками по линиям связи. Сигналы в модели могут быть измерены с помощью виртуальных измерительных устройств или рассмотрены и изучены с помощью виртуального осциллографа.

Внешне виртуальные блоки VisSim с некоторой степенью условности воспринимаются исследователем так же, как реальные устройства. Например, генераторы вырабатывают сигналы, блоки-преобразователи реагируют на входные сигналы в определенном смысле точно так же, как реальные устройства на реальные воздействия, индикаторы показывают величины сигналов.

Рис.1.5. (анимация 25 кадров). Пример последовательности действий при вынесении на рабочее пространство и перемещении блока надписи программы VisSim. Красные кружки вокруг курсора условно обозначают щелчки левой кнопкой мыши. Для запуска анимации, если рисунок не изменяется, следует щелкнуть по кнопке «Обновить» в верхней части браузера (окна, в котором вы читаете этот текст) или просто по рисунку. Для остановки некоторого кадра, чтобы его подробнее рассмотреть, следует щелкнуть в нужный момент по кнопке «Стоп» браузера

Т.о. принцип построения модели в VisSim’е состоит в вынесении на рабочее пространство моделей реальных элементов (блоков) и соединении их в соответствии с заранее составленной структурно-алгоритмической схемой моделируемой системы. Такое построение модели из виртуальных блоков очень похоже, с известной степенью условности, на построение реальной системы из настоящих блоков (генераторов, осциллографов, и других устройств) в производственных условиях или на лабораторном стенде.

1.4. Основные блоки VisSim

Блоки VisSim’а можно условно разделить на три основных категории и одну дополнительную:

  • Блоки, имеющие только выход: генераторы.
  • Блоки, имеющие вход и выход: преобразователи.
  • Блоки, имеющие только вход: индикаторы.
    • Осциллограф
    • Цифровой индикатор
  • Блоки без входов и выходов: надписи, комментарии и др.

Важным компонентом модели является соединительная линия – виртуальный аналог физического соединения элементов, передающего воздействия от одного элемента к другому. Соединительные линии в VisSim’е однонаправленные, передают сигналы с выхода одного блока к входу другого. Поэтому при построении модели следует так разделять реальную систему на функциональные блоки, чтобы последующий блок практически не влиял на функционирование предыдущего. Например, выходное электрическое сопротивление предыдущего блока должно быть значительно меньше входного сопротивления последующего блока.

Примечание: Входные и выходные сигналы могут быть как одиночными функциями времени, так и набором таких функций. В последнем случае сигнал называется векторным, как и соответствующий вход или выход блока.

1.4.1. Генераторы

Генераторы это блоки, имеющие только выход.

Генераторы вырабатывают изменяющиеся во времени или постоянные сигналы.

Примерами таких блоков в VisSim являются блоки:

  • step (ступенька) – генератор ступенчатой единичной функции 10(t);
  • ramp (спуск, подъем)– генератор линейно растущего сигнала t·10(t) ;
  • sinusoid – генератор синусоидального сигнала Xmsin(ωt+φ) ;
  • const – генератор постоянного сигнала, величина которого не меняется в процессе работы модели;
  • slider (скользящий контакт, ползунок) – генератор постоянного сигнала, величину которого можно менять в процессе работы модели.

Рис.1.6. Важные блоки-генераторы программы VisSim. Для помещения блока на рабочее пространство следует щелкнуть по пункту меню Blocks, перейти на пункт Signal Producer, затем щелкнуть по названию требуемого генератора, перевести курсор в нужное место рабочего пространства и щелкнуть левой кнопкой мыши

1.4.2. Преобразователи

Преобразователи это блоки, имеющие входы и выходы.

Блоки-преобразователи способны воспринимать воздействия от других блоков, преобразовывать их в соответствии с определенными уравнениями или правилами и выдавать преобразованный сигнал (отклик, реакцию блока) на выход.

Важнейшие блоки для моделирования линейных систем:

  • блок transferFunction – передаточная функция. Этот блок позволяет создавать модели как простых, так и очень сложных элементов линейных систем и систем в целом;
  • integrator – блок интегратора, осуществляющий интегрирование входного сигнала по времени и являющийся фундаментальным кирпичиком любой модели линейной системы;
  • summingJunction – сумматор двух и более сигналов, его выходной сигнал равен сумме входных.
  • gain – усилитель.

    • Рис. 1.7. Меню для вызова блока передаточная функция (transferFunction). Сумматор и усилитель вызываются путем выбора: Blocks → Arithmetic → summingJunction или gain (усилитель)

    1.4.3. Индикаторы

    Индикаторы это блоки, имеющие только вход.

    Индикаторы программы VisSim предназначены для отображения сигналов в форме удобной и привычной для исследователя.

    Важнейшими индикаторами являются блоки:

    • осциллограф – plot;
    • цифровой индикатор – display.

    Рис.1.8. Меню для вызова блоков plot (осциллограф), display (цифровой индикатор) и meter (стрелочный прибор) – важнейших виртуальных измерительных приборов программы VisSim

    Осциллограф

    Как показывает практика, не все студенты представляют себе назначение и принципы работы и использования реального, настоящего осциллографа. Поэтому кратко сообщим об этом.

    Осциллограф предназначен для графического представления в течение некоторого временного интервала зависимости мгновенной величины исследуемого сигнала от времени.

    Рис. 1.9. Внешний вид осциллографа С1-157. Ниже экрана ЭЛТ расположены входные разъемы, куда подаются исследуемые сигналы

    Основа осциллографа – электронная лучевая трубка ЭЛТ. Она имеет экран, на котором луч электронной пушки ЭЛТ высвечивает маленькое пятно. Трубка имеет отклоняющие луч системы, одна из которых, горизонтально-отклоняющая, равномерно перемещает луч, а, следовательно, и пятно, по экрану слева направо. Поэтому в течение времени развертки положение пятна на экране по горизонтальной оси пропорционально времени. Это способ представить, развернуть время в пространстве.

    На другую, отклоняющую луч по вертикали систему ЭЛТ, подается исследуемый, меняющийся во времени сигнал. Отклоняющая система ЭЛТ устроена так, что отклонение луча по вертикали пропорционально мгновенному значению исследуемого сигнала.

    Таким образом, луч, а, следовательно, и пятно на экране, участвуют одновременно в двух движениях: равномерном по горизонтали и, в соответствии с изменением величины сигнала во времени, по вертикали. В результате, на экране получается изображение зависимости сигнала от времени. Продолжительность временного отрезка, в течение которого наблюдается сигнал, называется временем развертки. Осциллографы позволяют наблюдать периодические сигналы, в этом случае используется периодическая развертка, частота которой подбирается в целое число раз меньшей, чем частота исследуемого сигнала. При наблюдении непериодических сигналов луч пробегает по экрану слева направо один раз, а трубка выбирается с длительным послесвечением люминофора.

    Рис. 1.10. Осциллограф развертывает на экране зависимость мгновенной величины сигнала от времени

    Виртуальный осциллограф VisSim’а представляет собой окно, похожее на экран осциллографа, в котором изображается зависимость наблюдаемых сигналов от времени (рис. 1.10). На боковой стороне осциллографа помещены условные изображения входов, к которым могут быть подключены выходы других блоков диаграммы для наблюдения поведения их сигналов в зависимости от времени.

    Цифровой индикатор

    Цифровой индикатор display VisSim’а – выводит, показывает в цифровом виде значение сигнала на выходе того блока, к которому он подключен. Этот прибор используется для измерения постоянных величин.

    1.4.4. Надписи и комментарии

    Надписи это блоки без входов и выходов.

    Эти блоки позволяют создавать на рабочем пространстве диаграммы VisSim текстовые области, которые помогают понять смысл диаграммы и содержат сведения о том, кто, когда и какую диаграмму создал. Основной блок: label – надпись.

    1.5. Принципы управления моделью и получения результатов моделирования

    Построенную модель следует запустить в работу, щелкнув по кнопке с зеленым треугольником [image] "Пуск" (рис. 1.3 и 1.5). В результате работы модели выходные сигналы блоков начнут изменяться, их величины просматривают на виртуальном осциллографе и других индикаторах. Параметры некоторых сигналов и блоков исследователь может изменять в процессе работы модели, другие параметры можно изменить, остановив процесс работы модели. Продолжительность работы модели можно задавать до ее запуска, можно и прерывать работу модели по желанию исследователя.

    1.6. Понятие о принципах функционирования программы VisSim

    После того, как модель построена, когда на рабочее пространство вынесены и соединены в нужном порядке блоки, составляющие систему, генераторы сигналов и индикаторы, а также введены параметры элементов модели, может быть запущен процесс ее функционирования. Для этого следует щелкнуть по кнопке с зеленым треугольником [image] "Пуск" (рис. 1.3 и 1.5).

    Получив эту команду, программа начинает анализировать то, как соединены блоки, на основе этого анализа составляет дифференциально-алгебраические уравнения, описывающие модель и решает их. Полученные результаты, как функции модельного времени, периодически и очень часто, придаются значениям входных и выходных сигналов блоков. Эта способность программы выполнять столь сложные, интеллектуальные действия, удивляет и восхищает.

    Дифференциально-алгебраические уравнения математически описывают т.н. динамические объекты, объекты очень широкого класса, обладающие инерционностью и рядом других свойств. И поскольку программа VisSim способна решать такие уравнения, то в ней можно моделировать системы и объекты очень широкого диапазона сложности.

    Решение уравнений проводится по шагам – дается малое приращение времени, вычисляются, с учетом начальных условий, значения сигналов на выходах и входах всех блоков, затем вновь дается малое приращение времени, проводятся вычисления и т.д. Малая величина шага интегрирования позволяет исследователю воспринимать сигналы как непрерывные. Выходные сигналы любого блока при желании можно наблюдать на экране виртуального осциллографа или измерять виртуальным цифровым индикатором. В результате решения можно получить зависимости выходных сигналов от времени. Таким образом, работа по моделированию систем в программе VisSim для исследователя похожа на работу на реальном стенде.

    Кроме того, программа позволяет более глубоко проанализировать полученные результаты и оптимизировать модель. Например VisSim предоставляет возможность быстрого построения частотных характеристик фрагментов модели и всей системы.

    Проиллюстрируем принцип работы программы Vissim на примере простой диаграммы:

    Рис. 1.8. Виртуальный генератор вырабатывает синусоидальный сигнал, соединительная линия передает его на вход осциллографа, осциллограф воспроизводит зависимость величины сигнала на его входе от времени. Например, через 0.25 сек после начала моделирования (щелчка по кнопке "Пуск") выходной сигнал генератора становится равным 0.72 условных единиц, эта величина А, и отображается точкой в названный момент времени на экране осциллографа

    При вынесении блока, т.е. при помещении исследователем на рабочее пространство программы условного изображения виртуального генератора, программа VisSim составляет его описание: номер, положение блока, частоту, амплитуду и начальную фазу синусоидального сигнала, который должен будет вырабатывать генератор и помещает эти данные в специальную таблицу. Аналогичные данные заносятся при вынесении на рабочее пространство виртуального осциллографа. При подключении выхода генератора к входу осциллографа с помощью соединительной линии, программа заносит в описание диаграммы номер генератора, с выхода которого идет сигнал, и номер и вход осциллографа, на который этот сигнал должен поступить при запуске моделирования. Все данные о диаграмме помещаются в файл диаграммы с расширением .vsm, создаваемый при сохранении диаграммы. Для генератора, вынесенного на рабочее пространство, программа резервирует ячейку памяти, в которой будет хранится и изменятся число, равное мгновенному значению выходного сигнала генератора в тот или иной моменты времени. Такая же ячейка создается и для соответствующего входа виртуального осциллографа.

    При запуске моделирования программа VisSim каждый такт вычисляет значение выходного сигнала генератора по формуле, показанной на рис. 1.11, соответствующее текущему значению времени (текущему такту) и помещает это значение в ячейку памяти, отведенную для хранения значений выходного сигнала генератора. В течение этого же такта программа определяет с помощью соединительной линии, куда нужно передать это значение и осуществляет передачу. В рассматриваемом примере значение передается из выходной ячейки памяти генератора во входную ячейку памяти осциллографа. Далее, в течение этого же такта вычислений, подпрограмма построения изображения осциллографа отмечает точку на его экране, горизонтальная координата которой пропорциональна времени, т.е. номеру текущего такта, а вертикальная - величине сигнала на входе осциллографа. В результате повторного многократного выполнения этих действий при изменении номера такта на экране осциллографа отобразится зависимость выходного сигнала генератора от времени.

    1.7. Версии VisSim

    В настоящее время доступны следующие версии VisSim [1]:
    • Академическая версия 3.0 - для некоторых Вузов поставляется фирмой Visual Solution Inc. бесплатно. Имеет некоторые ограничения и предназначена для использования в учебных, некоммерческих целях.
    • Студенческая версия – доступна бесплатно.
    • Версия 5 - возможности расширены, но бесплатно доступен только ознакомительный вариант.
    • Ознакомительная русифицированная версия. Выпущен только пилотный вариант, который может потребовать доработки, поэтому на сегодня предпочтительнее пользоваться академической версией на английском языке.

    Студенческую версию программы VisSim моделирования систем и объектов можно загрузить с сайта
    http://model.exponenta.ru/
    со страницы
    http://model.exponenta.ru/download.html
    [файл setupVisSimFAC.zip V3.0, 17.11.1999, 1100 KB] - студенческая версия программы VisSim (меньше дискетки).

    К началу раздела
    файла материалов >>

    2. Краткие сведения о программном комплексе "МВТУ"

    • 2.1. Принципы моделирования в ПК "МВТУ"
    • 2.2. Интерфейс ПК "МВТУ"
    • 2.3. Основные элементы модели
      • 2.3.1. Генераторы сигналов
      • 2.3.2. Элементы линейных систем
      • 2.3.3. Индикаторы и регистраторы
      • 2.3.4. Соединительные линии
    • 2.4. Простая модель
    • 2.5. Поясняющие надписи

Программный комплекс "МВТУ" (моделирование всевозможных технических устройств, объектов и систем) разработан в МГТУ им. Н.Э.Баумана коллективом авторов под руководством доцента О.С. Козлова и предназначен для моделирования и исследований проектируемых и действующих систем и объектов. Комплекс позволяет моделировать объекты широкого спектра сложности: от простейших элементов систем управления до систем управления ядерными реакторами, для чего собственно он и создавался. В последнем случае ПК "МВТУ" позволяет создавать виртуальные тренажеры даже для тренировки операторов атомных электростанций.

Достоинства программного комплекса "МВТУ":

  • русскоязычный графический интерфейс. Это единственная программа в своем классе, «говорящая» по-русски;
  • простота построения моделей, управления их работой, проведения исследований и получения их результатов;
  • возможность при желании обойтись при построении моделей без записи программного кода. В то же время, в случае необходимости, комплекс позволяет воспользоваться мощным математическим аппаратом;
  • относительно высокое быстродействие, позволяющее моделировать многие системы в реальном и ускоренном масштабах времени;
  • возможность создания анимации, позволяющей воссоздавать внешний облик работающих и исследуемых объектов и измерительных приборов, что увеличивает наглядность модели.

    • Советы

    ПК "МВТУ", как и любая программа, имеющая графический интерфейс, требует некоторого периода адаптации, привыкания к внешнему виду панелей и способам работы. После запоминания назначения основных инструментов управления и приобретения некоторых навыков составления структурных схем и задания параметров их элементов новичок начинает чувствовать комфорт, о создании которого позаботились разработчики.

    Для удобства знакомства с программой, используя данное пособие, целесообразно окна ПК "МВТУ" поместить в верхней части экрана, а окно с методическими указаниями к лабораторной работе расположить в нижней части экрана, примерно вот так

    Расположение окон ПК "МВТУ" и методического пособия по его изучению.

    В этом случае переход от пособия к изучаемому комплексу и обратно упрощается. Разрешение экрана полезно установить в 800х600 или выше.

    Для экономии места некоторые рисунки выполнены с применением анимации, для ee запуска может потребоваться щелкнуть по кнопке Обновить браузера (окна, в котором вы читаете этот текст).

    2.1. Принципы моделирования в ПК "МВТУ"

    Принцип моделирования в ПК "МВТУ" состоит в создании и исследовании виртуального аналога реальной системы – модели. Модель функционирует в соответствии с теми же уравнениями, что и моделируемая система. При моделировании не обязательно записывать эти уравнения в явном виде, об этом позаботится программа. Модель составляется пользователем на т.н. рабочем пространстве программы вынесением на него и соединением отдельных виртуальных блоков, соответствующих элементам реальной системы.

    Виртуальные блоки условно внешне представляются на рабочем пространстве окна модели прямоугольниками, т.е. они видимы исследователю, имеют входы и (или) выходы и функционируют в соответствии с определенными уравнениями, алгоритм решения которых реализуется в цифровом виде. Под функционированием виртуального блока понимается то, что он реагирует на виртуальные воздействия (функции времени), подаваемые другими блоками на его вход, определенным изменением величины выходного сигнала.

    Взаимодействие между блоками условно отображается на рабочем пространстве окна модели в виде соединительных линий. Соединительные линии в ПК "МВТУ", как и блоки, являются однонаправленными, передают виртуальные воздействия только в одном направлении. Другими словами, последующие блоки и звенья не влияют на работу предыдущих. Для модели электрической цепи, например, это означает, что выходное сопротивление предыдущего блока значительно меньше входного сопротивления последующего блока. Сигналы, действующие в модели можно наблюдать и регистрировать виртуальными индикаторами. Для этого программа создает специальные окна с временными, частотными графиками, фазовыми портретами и др.

    Параметры и характеристики блоков, как и структуру схемы модеи, исследователь может изменять. Программа предоставляет возможность вычислять различные характеристики построенных моделей, в частности амплитудно-частотные, анализируя которые можно глубоко изучить свойства модели, а, следовательно, и моделируемой реальной системы.

    Модель ПК "МВТУ" может быть сохранена в виде отдельного файла и, при необходимости, открыта вновь.

    2.2. Интерфейс ПК "МВТУ"

    Интерфейс программы это совокупность средств, позволяющих человеку общаться с ней:

    • вводить и получать данные,
    • подавать управляющие воздействия и наблюдать реакцию на них программы,
    • контролировать ход ее выполнения и т.п.

    Программный комплекс "МВТУ" использует развитой графический интерфейс, позволяющий основную часть создания модели выполнить с помощью мыши, а параметры элементов ввести с клавиатуры. Интерфейс ПК "МВТУ" состоит из основной панели (главного окна), имеющей меню и ряд кнопок управления, воспринимающих щелчки копок мыши, и совокупности окон, в которых строится модель и наблюдаются результаты ее работы.

    Основная панель – главное окно программы, появляющееся в верхней части экрана после запуска ПК "МВТУ" (рис. 2.1).

    Рис. 2.1. Основная панель ПК ""МВТУ"". Выделены кнопка Пуск (Продолжить расчет) и три важных вкладки Палитры с наборами элементов (виртуальных блоков), которые будут использоваться при моделировании: Источники сигналов (генераторы) – вкладка открыта, Данные (индикаторы и регистраторы) и Динамические блоки (элементы линейных систем и систем в целом).

    Верхняя часть главного окна – панель управления. Она содержит меню и кнопки управления и настройки. Нижняя часть главного окна это т.н. Палитра блоков – структурированный набор вкладок, содержащих образцы моделей различных элементов, которые могут быть вынесены в окно модели (схемное окно). При необходимости палитра блоков может быть перенесена на другое место или вовсе удалена с экрана для освобождения места для схемы модели, индикаторов и др. На рис.1 выделены три важных набора элементарных блоков: генераторы, индикаторы и модели линейных элементов, которые позволяют строить модели линейных систем и объектов и будут подробнее рассмотрены ниже. Кнопки в правой верхней части палитры позволяют просматривать и другие вкладки, с наборами соответствующих блоков, в частности, вкладку Анимация .

    2.3. Основные элементы модели

    2.3.1. Генераторы сигналов

    Генераторы сигналов размещены на вкладке Источники основной панели (рис. 2.2):

    Рис. 2.2. Часть набора виртуальных генераторов, имеющихся на вкладке Источники. Важными источниками сигналов являются генераторы ступенчатого и синусоидального сигналов. Кнопка со стрелкой Вправо позволяет посмотреть и другие источники сигналов.

    2.3.2. Элементы линейных систем

    Блоки, моделирующие элементы линейных систем и объектов различной сложности помещены на вкладке Динамические (рис. 2.3):

    Рис. 2.3. На вкладке Динамические блоки помещены образцы моделей элементов линейных систем. Для начала, обратим внимание на интегратор, апериодическое и колебательное звенья.

    2.3.3. Индикаторы и регистраторы

    Рис. 2.4. Важный регистратор – виртуальный осциллограф (блок Временной график).

    Примечание: программа позволяет создавать и собственные варианты индикаторов с помощью инструментов, расположенных на вкладке Анимация (в правой части Палитры).

    2.3.4. Соединительные линии

    Соединительные линии позволяют отобразить взаимодействие между отдельными элементами реальной системы. В ПК "МВТУ" соединительные линии однонаправленные: они передают виртуальные сигналы с выходов блоков на их входы. Это означает, что в моделируемых системах последующие блоки не должны влиять на работу предыдущих блоков. Такое требование следует выполнить при составлении функциональной схемы моделируемой системы, должным образом выделяя ее функциональные элементы. Линии проводятся от одного блока модели к другому с помощью мыши. Пример соединительных линий можно видеть в левом нижнем окне модели рис. 2.5.

    2.4. Простая модель

    На рис. 2.5 показана простая модель, состоящая всего из одного блока – апериодического звена и результаты его исследования, состоявшего в определении реакции этого звена на ступенчатое воздействие, так называемой переходной функции.

    Рис. 2.5. Определение переходной функции апериодического звена. На левое нижнее окно модели вынесены генератор ступенчатого сигнала, апериодическое звено, осциллограф и соединены друг с другом. При запуске модели, нажатием на кнопку Пуск (Продолжить расчет CTRL+ F9) - бегущий человечек, на осциллографе появляется график реакции звена на ступенчатое воздействие – его переходная функция.

    Виртуальный генератор в нулевой момент времени подает на вход апериодического звена ступенчатое единичное воздействие, на которое звено откликается все замедляющимся ростом выходного сигнала. Виртуальный осциллограф позволяет увидеть изменение выходного сигнала звена с течением времени и проанализировать его.

    2.5. Поясняющие надписи.

    Сопровождение модели поясняющими надписями позволяет облегчить ее восприятие и работу с ней. В пояснении нужно указать кто, когда и какую модель создал. В "МВТУ" можно создавать пояснения двух видов: заметку, текст которой виден вместе с блоками модели и комментарий, текст которого открывается в отдельном окне, при двукратном щелчке по квадратному блоку со знаком вопроса. Блоки заметки (без обозначения) и комментария (квадрат со знаком вопроса) «затерялись» в правой части вкладки Субструктуры (рис. 2.6):

    Рис. 2.6. Блоки заметка и комментарий выносятся на рабочее пространство окна модели с вкладки Субструктуры. Внизу показано окно просмотра и редактирования комментария.

    Мини-версию моделирующего программного комплекса "МВТУ" можно загрузить со страницы
    http://energy.power.bmstu.ru/mvtu/

    К началу раздела
    файла материалов >>

    3.1. Характеристики типовых звеньев

    № | Название | Характеристики
1 | Интегратор |
2 | Апериодическое звено |
3 | Колебательное звено и апериодическое звено второго порядка |

    К началу раздела
    файла материалов >>

    3. 2. Теоремы о соединении звеньев

    № | Тип соединения звеньев | Описание
1 | Последовательное |
2 | Параллельное согласное |
3 | Параллельное встречное |

    К началу раздела
    файла материалов >>

    Далее >>

    К содержанию >>


ТАУ ЮНИТА 1 Перечень умений

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Перечень умений

В данном разделе дается перечень основных навыков решения типовых задач, которыми должен владеть студент после освоения материала первой юниты, а также алгоритмы их решения - порядок рассуждений и действий.

№

Умение

Алгоритм

1

Определить тип САР
по ее структурной схеме

Найти на схеме объект управления, его управляемую величину, задающую величину САР, устройство сравнения (если оно есть) и регулятор. Определить, имеется ли в САР главный контур управления. Если он есть, то САР реализует управление по отклонению.

Если главного контура управления нет, то САР разомкнутая. Если в этом случае на регулятор поступает сигнал возмущения, то схема САР разомкнутая, с управлением по возмущению, если не поступает - схема разомкнутая, с жестким управлением.

Если на регулятор подается сигнал рассогласования от устройства сравнения и возмущение, то схема САР комбинированная, с управлением как по отклонению, так и по возмущению.

2

Определить тип
и параметры звена
по его переходной функции

Если переходная функция звена растет линейно и неограниченно, то это интегратор. Его постоянная времени совпадает со временем, за которое переходная характеристика достигает уровня единицы.

Если переходная функция начинает расти линейно, а затем скорость ее роста постепенно уменьшается и характеристика стремится асимптотически к некоторому уровню, то звено - апериодическое. Уровень определяет коэффициент усиления звена, а момент пересечения касательной, проведенной в нулевой момент времени к переходной характеристике - его постоянную времени.

Если переходная функция в нулевой момент времени идет горизонтально, а затем с колебаниями или без них стремится к некоторому уровню, то это колебательное звено. Размах колебаний и время их затухания определяют постоянную времени и декремент затухания звена (см. рис. 3.14 в гл. 3). Коэффициент усиления определяется уровнем, к которому стремиться переходная функция.

3

Определить тип
и параметры звена
по его ЛАЧХ и ЛФЧХ

Если ЛАЧХ звена убывает линейно со скоростью - 20 дБ, то это интегратор. Его постоянная времени обратна частоте, на которой ЛАЧХ пересекает уровень 0 дБ.

Если ЛАЧХ звена на низких частотах проходит горизонтально, а начиная с некоторой частоты убывает линейно со скоростью - 20 дБ, то это апериодическое звено. Его постоянная времени обратно пропорциональна частоте точки сопряжения линейных участков аппроксимации. Уровень, на котором проходит ЛАЧХ на нижних частотах определяется коэффициентом усиления L(ω) = 20lg(|k|). Отсюда не трудно определить его значение k.

Если ЛАЧХ звена на низких частотах проходит горизонтально, а начиная с некоторой частоты убывает линейно со скоростью - 40 дБ, то это колебательное звено. Его коэффициент усиления определяется так же как у апериодического звена, а другие параметры определяются в соответствии с рис. 3.11 в гл. 3.

4

Определить амплитуду и начальную фазу
выходного сигнала
линейного звена при подаче
на его вход синусоидального сигнала

По частотной характеристике звена определить его усиление на частоте входного сигнала и найти амплитуду выходного сигнала умножением амплитуды входного сигнала на найденный коэффициент усиления.

По фазочатотной характеристике определить величину фазовой задержки звена на частоте входного сигнала и найти начальную фазу выходного синусоидального сигнала звена, сложив начальную фазу входного сигнала и найденную фазовую задержку звена.

5

Определить тип соединения звеньев и записать их передаточную функцию

Сравнить рассматриваемую схему с определениями типов соединения звеньев, выбрать соответствующий тип и, пользуясь теоремами о соединении звеньев, найти их передаточную функцию по формуле.

6

Найти ЛАЧХ и ЛФЧХ
последовательного соединения звеньев

Построить ЛАЧХ и ЛФЧХ первого звена, второго звена, а затем сложить их.

7

Привести структурную схему
заданной САР с управлением по
отклонению к типовому виду

Найти объект управления, устройство сравнения (сумматор главного контура управления), задающую и управляемую величины. Пользуясь теоремами о соединении звеньев сгруппировать оставшиеся элементы в один и поместить его после сумматора и перед объектом управления. Обратная связь должна получиться жесткой, единичной.

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 Перечень знаний

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Перечень знаний

В результате изучения ЮНИТы 1 студент приобретет знания:

  • - Основных понятий и определений теории автоматического управления.
  • - Принципов автоматического управления и их структурной и функциональной реализации.
  • - Способов описания линейных систем автоматического управления, их общих свойств и характеристик.
  • - Типовых звеньев, их свойств и характеристик, способов описания отдельных звеньев и их соединений, их идентификации.
  • - Способа приведении схемы САР с управлением по отклонению к типовому виду. Основных передаточных функций типовой САР, ее уравнений динамики и статики.

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 ТРЕНИНГ УМЕНИЙ

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

ТРЕНИНГ УМЕНИЙ

Раздел предназначен для приобретения и закрепления студентом навыков решения типовых задач, связанных с описанием систем автоматического управления и их элементов. По каждому разделу, рассматриваемому в первых четырех лекциях, дается пример решения задачи на основе стандартного алгоритма и предлагаются задачи для самостоятельного решения.

Содержание
  1. Определение типов систем автоматического регулирования (САР) по их функциональным схемам
    2.
  2. Определение параметров звеньев по их переходным функциям
    3.
  3. Определение параметров звеньев по их частотным характеристикам
    4.
  4. Определение параметров выходного сигнала линейной САР
    5.
  5. Определение передаточных функций системы звеньев
    6.
  6. Построение частотных характеристик последовательного соединения звеньев
    7.
  7. Приведение схемы произвольной САР к типовому виду

1. Пример выполнения упражнения тренинга на умение 1

Определение типов систем автоматического регулирования (САР)
по их функциональным схемам

Задание

Дана функциональная схема САР частоты вращения вала двигателя постоянного тока (ДПТ):

Рис. Т 1.1. САР ЧВ ДПТ. ДПТ - двигатель постоянного тока, У – усилитель, Г – генератор, ТГ – тахогенератор (датчик частоты вращения вала)

Определить тип САР.

Решение

Выполните последовательность действий в соответствии с алгоритмом, указанным в перечне для умения №1.

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
1 | Найти на схеме объект управления, его управляемую величину, задающую величину САР, устройство сравнения (если оно есть) и регулятор. | Объект управления - ДПТ, его управляемая величина - частота вращения вала n [об/сек], задающая величина САР это напряжение хз, [В], устройство сравнения есть, это сумматор. Регулятором можно считать последовательное соединение усилителя и генератора.
2 | Определить, имеется ли в САР главный контур управления. Если он есть, то САР реализует управление по отклонению. | Главный контур управления в САР имеется.
3 | Если на регулятор подается сигнал рассогласования от устройства сравнения и возмущение, то схема САР комбинированная, с управлением как по отклонению, так и по возмущению. | На регулятор возмущение не подается. Ответ: на схеме приведена замкнутая САР с управлением по отклонению

Выполните самостоятельно следующие задания

Задание 1.1

Дана функциональная схема САР частоты вращения вала двигателя постоянного тока (ДПТ):

Рис. Т 1.2. ДПТ - двигатель постоянного тока, У – усилитель, Г – генератор

Определить тип САР.

Задание 1.2

Дана функциональная схема САР частоты вращения вала двигателя постоянного тока (ДПТ):

Рис. Т 1.3.

Определить тип САР.

Задание 1.3

Дана функциональная схема САР частоты вращения вала двигателя постоянного тока (ДПТ):

Рис. Т 1.4.

Определить тип САР.

К содержанию раздела >>

2. Пример выполнения упражнения тренинга на умение 2

Определение параметров звеньев по их переходным функциям

Задание

Дана переходная характеристика некоторого звена:

Рис. Т 2.1. Осциллограммы ступенчатой функции и переходной функции некоторого звена

Определить тип звена, его коэффициент усиления и длительность переходного процесса.

Решение

Выполните последовательность действий в соответствии с алгоритмом, указанным в перечне для умения №2.

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
1 | Если переходная функция в начальные моменты времени идет горизонтально, а затем с колебаниями или без них стремится к некоторому уровню, то это колебательное звено. | Переходная характеристика в нулевой момент времени имеет нулевую производную, с течением времени стремится с переколебанием к уровню 8 единиц. Звено - колебательное.
2 | Коэффициент усиления определяется уровнем, к которому стремиться переходная функция. | Коэффициент усиления равен 8 единицам.
3 | Длительность переходного процесса определяется по моменту времени, когда переходная характеристика начинает отличаться от асимптотического значения менее, чем на 5% его величины. | Длительность переходного процесса составляет примерно (см. рис. Т 2.1) 5 - 5.5 сек.

Выполните самостоятельно следующие задания

Задание 2.1

Дана переходная характеристика некоторого звена:

Рис. Т 2.2. Осциллограммы ступенчатой функции и переходной функции некоторого звена

Определить тип звена, его коэффициент усиления, длительность переходного процесса и постоянную времени.

Задание 2.2

Дана переходная характеристика некоторого звена:

Рис. Т 2.3. Осциллограммы ступенчатой функции и переходной функции некоторого звена

Определить тип звена, его коэффициент усиления и постоянную времени.

Задание 2.3

Дана переходная характеристика некоторого звена:

Рис. Т 2.4. Осциллограммы ступенчатой функции и переходной функции некоторого звена

Определить тип звена и его коэффициент усиления.

К содержанию раздела >>

3. Пример выполнения упражнения тренинга на умение 3

Определение параметров звеньев по их частотным характеристикам

Задание

Даны логарифмические амплитудно – и фазо - частотные характеристики (ЛАЧХ и ЛФЧХ) некоторого звена:

Рис. Т 3.1. ЛАЧХ и ЛФЧХ линейного звена

Определить тип звена, его коэффициент усиления и постоянную времени. Записать выражения для передаточной и переходной функций этого звена.

Решение

№

Алгоритм

Конкретное соответствие данной ситуации
предложенному алгоритму

1

Определить крутизну ЛАЧХ на нижних и высоких частотах.

Если ЛАЧХ звена на низких частотах проходит горизонтально, а начиная с некоторой частоты убывает линейно со скоростью - 40 дБ, то это колебательное звено.

ЛАЧХ звена на низких частотах проходит горизонтально, а начиная с некоторой частоты, большей 1 рад/сек, убывает линейно со скоростью - 40 дБ.

Звено - колебательное. Вывод подтверждается и тем, что на высоких частотах ЛФЧХ стремится к величине - 1800

Рис. Т .3.2. На низких частотах ЛАЧХ идет горизонтально (0 дБ/дек), на высоких частотах ЛАЧХ имеет наклон – 40 дБ/дек, а ЛФЧХ стремится к - 1800. Звено колебательное

Параметры звена: коэффициент усиления, постоянная времени и декремент затухания определяются в соответствии с рис. Т 3.3:

Рис. Т 3.3. Постоянная времени колебательного звена обратно пропорциональна частоте, на которой ЛФЧХ равна – 90, а также равной ей частоте сопряжения линейных участков аппроксимации ЛАЧХ. Уровень, на котором ЛАЧХ проходит на низких частотах, определяет величину коэффициента усиления k. Высота резонансного пика определяется декрементом затухания δ

Как видно из рис., параметры колебательного звена следующие:

  • - коэффициент усиления равен 12;
  • - постоянная времени равна 1 сек;
  • - декремент затухания равен 0.5.

Поэтому, в соответствии с формулами (3.20) и (3.25) передаточная функция звена имеет вид:

а переходная функция:

Выполните самостоятельно следующие задания

Задание 3.1

Даны логарифмические амплитудно – и фазо- частотные характеристики (ЛАЧХ и ЛФЧХ) некоторого звена:

Рис. Т 3.4. ЛАЧХ и ЛФЧХ линейного звена

Определить тип звена, его коэффициент усиления и постоянную времени. Записать выражения для передаточной и переходной функций этого звена.

Задание 3.2

Даны логарифмические амплитудно – и фазо - частотные характеристики (ЛАЧХ и ЛФЧХ) некоторого звена:

Рис. Т 3.5. ЛАЧХ и ЛФЧХ линейного звена

Определить тип звена, его коэффициент усиления и постоянную времени. Записать выражения для передаточной и переходной функций этого звена.

К содержанию раздела >>

4. Пример выполнения упражнения тренинга на умение 4

Определение параметров выходного сигнала линейной САР

Задание

Дано звено с передаточной функцией:

(Т 4.1)

На его входе действует синусоидальный сигнал:

(Т 4.2)

x(t) = 8 ·sin(30t + 300)

Найти амплитуду и начальную фазу выходного сигнала и записать его выражение.

Решение

№

Алгоритм

Конкретное соответствие данной ситуации
предложенному алгоритму

1

По частотной характеристике звена определить его усиление на частоте входного сигнала и найти амплитуду выходного сигнала умножением амплитуды входного сигнала на найденный коэффициент усиления.

По фазо - частотной характеристике определить величину фазовой задержки звена на частоте входного сигнала и найти начальную фазу выходного синусоидального сигнала звена, сложив начальную фазу входного сигнала и найденную фазовую задержку звена.

Входной сигнал синусоидальный, подается на колебательное звено (Т 4.1), которое является линейным.

Поэтому его выходной сигнал может быть найден по указанному алгоритму.

Из (Т 4.1) в соответствии с формулой (3.20) лекций видно, что

  • - коэффициент усиления звена равен 6;
  • - квадрат постоянной времени равен 0.01, следовательно, постоянная времени равна Т = 0.1 сек;
  • - декремент затухания δ равен 0.2/2Т = 1.

Из (Т 4.2) видно, что амплитуда входного сигнала равна 8, частота 30 рад/сек, начальная фаза 300.

Решение. Способ 1

Усиление или модуль комплексного коэффициента передачи (ККП) колебательного звена с передаточной функцией (Т 4.1) определяется формулой (3.22) лекций:

(Т 4.3)

На частоте 30 рад/сек модуль комплексного коэффициента передачи (ККП) равен:

(Т 4.4)

Амплитуда выходного сигнала звена равна в соответствии с формулой (2.18) лекций:

(Т 4.5)

Ym = Xm · |W(30)| = 8 · 0.60 = 4.8

Аргумент комплексного коэффициента передачи (фазочастотная характеристика) колебательного звена определяется формулой (3.21) лекций:

(Т 4.6)

Значение аргумента на частоте 30 рад/сек равно

(Т 4.7)

Начальная фаза выходного сигнала в соответствии с формулой (2.20) лекций равна

(Т 4.8)

Таким образом, выходной сигнал колебательного звена примет вид:

(Т 4.9)

y(t) = 4.8 sin(30·t – 113.10)

Решение. Способ 2.

Если у Вас под рукой есть программа MathCAD, то усиление и аргумент ККП на частоте входного сигнала ω = 30 рад/сек можно получить следующим образом:

Рис. Т 4.1. Снимок документа MathCAD. Усиление и аргумент ККП определены двумя способами: непосредственным вычислением и определением по предварительно построенным АЧХ и ФЧХ

Далее так же, как в (Т 4.5) и (Т 4.8).

Решение. Способ 3

Решение в программе VisSim.

Рис. Т 4.2. Снимок диаграммы VisSim. Модуль комплексного коэффициента передачи |W(30)| находится отношением амплитуд выходного и входного сигналов по завершении переходного процесса. Усиление и аргумент ККП могут быть определены как по временным, так и по частотным характеристикам звена

Далее так же, как в (Т 4.5) и (Т 4.8).

Выполните самостоятельно следующие задания

Задание 4.1

Дано звено с передаточной функцией:

(Т 4.10)

На его входе действует синусоидальный сигнал:

(Т 4.11)

x(t) = 4 sin(10·t - 300)

Найти амплитуду и начальную фазу выходного сигнала и записать его выражение.

Задание 4.2

Дана система из двух звеньев с передаточной функцией:

(Т 4.12)

На ее входе действует синусоидальный сигнал:

(Т 4.13)

x(t) = 5 sin(10·t - 600)

Найти амплитуду и начальную фазу выходного сигнала и записать его выражение.

К содержанию раздела >>

5. Пример выполнения упражнения тренинга на умение 5

Определение передаточных функций системы звеньев

Задание

Дан фрагмент структурной схемы САР:

Рис. Т 5.1.

Передаточные функции звеньев равны:

(Т 5.1)

Назвать тип соединения и записать передаточную функцию этого фрагмента.

Решение

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
1 | Сравнить рассматриваемую схему с определениями типов соединения звеньев, выбрать соответствующий тип и, пользуясь теоремами о соединении звеньев, найти их передаточную функцию по соответствующей формуле. | Ответ Тип соединения: параллельное встречное

Передаточная функция фрагмента:

(Т 5.2)

Таким образом, охват интегратора жесткой обратной связью дает апериодическое звено

Выполните самостоятельно следующие задания

Задание 5.1

Дан фрагмент структурной схемы САР:

Рис. Т 5.2.

Передаточные функции звеньев равны:

(Т 5.3)

Назвать тип соединения и записать передаточную функцию этого фрагмента.

Задание 5.2

Дан фрагмент структурной схемы САР:

Рис. Т 5.3.

Передаточные функции звеньев равны:

(Т 5.3)

Назвать тип соединения и записать передаточную функцию этого фрагмента. Составить эквивалентную схему, состоящую из последовательного соединения форсирующего и интегрирующего звеньев.

К содержанию раздела >>

6. Пример выполнения упражнения тренинга на умение 6

Построение частотных характеристик последовательного соединения звеньев

Задание

Дан фрагмент структурной схемы САР:

Рис. Т 6.1.

Передаточные функции звеньев равны:

(Т 6.1)

Построить ЛАЧХ этого фрагмента.

Решение

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
1 | Построить ЛАЧХ и ЛФЧХ первого звена, второго звена, а затем сложить их. | Соединение звеньев последовательное, следовательно ЛАЧХ этого соединения находится суммированием ЛАЧХ отдельных звеньев

(Т 6.2)

Рис. Т 6.2. ЛАЧХ и ЛФЧХ последовательного соединения звеньев равны сумме ЛАЧХ и ЛФЧХ отдельных звеньев

В программе VisSim можно сразу получить ЛАЧХ и ЛФЧХ последовательного соединения звеньев (см. [1.3] в списке основной литературы).

Выполните самостоятельно следующие задания

Задание 6.1

Дан фрагмент структурной схемы САР:

Рис. Т 6.3.

Передаточные функции звеньев равны:

(Т 6.3)

Записать выражения для переходных функций звеньев и найти переходную функцию фрагмента схемы, приведенного на рис. Т 6.3.

К содержанию раздела >>

7. Пример выполнения упражнения тренинга на умение 7

Приведение схемы произвольной САР к типовому виду

Задание

Дана структурная схема САР частоты вращения вала двигателя постоянного тока (ЧВ ДПТ) с управлением по отклонению, на вход которой подключен генератор единичного ступенчатого воздействия, а к выходу присоединен осциллограф:

Рис. Т 7.1. САР ЧВ ДПТ. Структура ДПТ показана справа внизу

Привести структурную схему САР с управлением по отклонению к типовому виду.

Решение

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
1 | Найти объект управления, устройство сравнения (сумматор главного контура управления), задающую и управляемую величины. | Объект управления - ДПТ. Устройство сравнения главного контура управления - левый сумматор. Задающее воздействие - ступенчатый сигнал генератора. Управляемая величина - частота вращения n вала ДПТ, это выходной сигнал ДПТ.

Рис. Т 7.2. Объединение элементов САР ЧВ ДПТ для представления САР в типовом виде

№ | Алгоритм | Конкретное соответствие данной ситуации предложенному алгоритму
2 | Пользуясь теоремами о соединении звеньев сгруппировать оставшиеся элементы в один и поместить его после сумматора и перед объектом управления. Обратная связь должна получиться жесткой, единичной. | См. рис. Т 6.3.

Рис. Т 7.3. Типовой вид САР. Возмущение приведено к выходу ДПТ, датчик включен в состав объекта управления. Обратная связь жесткая, единичная.

Выполните самостоятельно следующие задания

Задание 7.1

Дана структурная схема САР «Ветер В-0» частоты вращения вала двигателя постоянного тока (ЧВ ДПТ) с управлением по отклонению, на вход которой подключен генератор ступенчатого единичного воздействия, а к выходу присоединен осциллограф:

Рис. Т 7.4. Структурная схема САР «Ветер В-0»

Привести структурную схему САР к типовому виду.

К содержанию раздела >>

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 Самостоятельная работа

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Самостоятельная работа

Перечень тем лекций

    Лекция 1
    Характеристика объектов и систем автоматического управления
    Лекция 2
  • Уравнения, модели и характеристики линейных систем

    • Лекция 3
  • Типовые звенья САР

    • Лекция 4
  • Соединение звеньев и преобразование структурных схем. Типовая схема САР

Задания на СРС

Изучить материал лекций.

Подготовиться к выполнению и защите лабораторных работ № 1 - № 2 по курсу ТАУ. Содержание и объем подготовки изложен в методических указаниях к выполнению работ [3].

Примечание. Студентам, обучающимся дистанционно, рекомендуется выполнить названные лабораторные работы на домашних компьютерах.

Студенческую версию программы VisSim моделирования систем и объектов можно загрузить со страницы
http://model.exponenta.ru/download.html
[setupVisSimFAC.zip V3.0, 17.11.1999, 1100 KB] - студенческая версия программы VisSim (меньше дискетки).

Мини-версию моделирующего программного комплекса "МВТУ" - русскоязычного аналога VisSim можно загрузить со страницы
http://energy.power.bmstu.ru/mvtu/

Литература для СРС

Основная:
  1. Лукас В.А. Теория автоматического управления. - М. :Недра, 1990г., 416 стр.
  2. ТАУ, под ред. Ю.М. Соломенцева, - М., ВШ, 2002 г.
  3. Федосов Б.Т. Методические указания к выполнению лабораторных работ № 1 - № 2 по курсу ТАУ. Электронные документы в формате .chm справки Windows. - Рудный, РИИ, 2002 - 2004 гг.
    http://model.exponenta.ru/tau.html
    tau_lr_light.zip 955 KB, 22.05.2004
    http://model.exponenta.ru/tau_lr_light.zip
Дополнительная:
  1. Федосов Б.Т. Задания и методические указания к выполнению лабораторной работы № 0 по курсам Информатика, Системотехника и ТАУ на тему:
    Первое знакомство с компьютером.
    Знакомство с операционной системой Windows.
    Рабочий стол.
    Стандартные программы: Блокнот, Калькулятор, Paint.
    Электронный документ в формате .chm справки Windows 1.13 МБ. - Рудный, РИИ, 2004 г.

Далее >>

К содержанию >>


ТАУ ЮНИТА 1 Глоссарий терминов

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Глоссарий терминов

В этом разделе даны определения основных понятий теории автоматического управления.

А Б В Г Д Е Ж З И К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Э Ю Я

  • Автоматическое регулирование
    Поддержание постоянной (стабилизация) или меняющейся во времени по некоторому закону (слежение) величины, характеризующей объект управления.
  • Автоматическое управление
    Это подача на объект управления совокупности воздействий с целью обеспечения оптимального, в некотором определенном смысле, функционирования объекта. Совокупность воздействий выбирается из множества возможных.
  • Адекватность модели
    Соответствие модели реальной системе. Достигается только с некоторой точностью.
  • Астатическая САР
    САР с управлением по отклонению, в контуре которой находится по крайней мере один интегратор, не охваченный обратными связями. Такая САР отслеживает безошибочно по крайней мере постоянный сигнал.
  • Амплитудно-частотная характеристика (АЧХ)
    Зависимость модуля комплексного коэффициента передачи некоторого звена от частоты. Другими словами, это зависимость величины усиления звеном синусоидального сигнала от частоты этого сигнала.
  • Анализ системы управления
    Изучение ее структуры, свойств и характеристик. Осуществляется на основе построения моделей системы управления.
  • Апериодическое (инерционное) звено
    Это звено - простейшее из моделей линейных систем, обладающих инерционностью. Функционально звено содержит один накапливающий (реактивный) элемент и хотя бы один рассеивающий (активный).
  • АЧХ - амплитудно-частотная характеристика
    Зависимость коэффициента усиления линейным звеном синусоидального сигнала, т.е. модуля комплексного коэффициента передачи, от частоты.
  • Весовая функция
    Реакция линейной системы или звена на дельта-функцию Дирака (на практике - на достаточно короткий импульс).
  • Возмущение
    Это воздействие (помеха), поступающее на объект управления и препятствующее его требуемому поведению.
  • Годограф комплексного коэффициента передачи
    линейного звена или системы это кривая на комплексной плоскости, которую пробегает конец вектора комплексного коэффициента передачи при изменении частоты от нуля до бесконечности. По годографу ККП разомкнутого контура САР судят о ее свойствах, в частности о качестве регулирования.
  • Динамический режим работы САР
    Это работа САР при изменяющихся во времени задании и возмущении. В динамическом режиме проявляются инерционные свойства САР. Частные случаи динамического режима: переходный и установившийся режимы.
  • Задающая величина
    Величина, подаваемая на вход системы регулирования. В соответствии с задающей величиной должна изменяться выходная, управляемая величина объекта управления.
  • Замкнутая САР с управлением по отклонению
    Система управления, в которой регулятор вырабатывает управляющие воздействия на объект на основе определения отклонения управляемой величины от задающей.
  • Звено запаздывания
    Устройство, выходной сигнал которого, оставаясь неизменным по форме и масштабу, отстает по времени от входного на некоторую величину.
  • Интегратор
    Звено, выходной сигнал которого пропорционален интегралу по времени от входного. Например, емкость, в которую поступает жидкость, или вал двигателя.
  • Качество САР
    Мера способности САР решать поставленные перед ней задачи: осуществлять слежение и стабилизацию. Характеризуется точностью и быстродействием в переходном и установившемся режимах.
  • Кибернетика - наука об управлении.
    Основывается на изучении процессов протекающих в объектах управления, на изучении того, как эти объекты реагируют на внешние воздействия и определении способов воздействия на объект с тем, чтобы оптимизировать его состояние и поведение.
  • Колебательное звено
    Простейшая из линейных систем, обладающих колебательностью, т.е. способностью колебательно возвращаться в исходное состояние после прекращения воздействия. Состоит из двух реактивных элементов, способных накапливать энергию разного вида (кинетическую и потенциальную, электрическую и магнитную) и хотя бы одного активного элемента, способного ее рассеивать.
  • Комплексный коэффициент передачи
    Функция мнимого аргумента, связывающая спектры входного и выходного сигналов линейного звена.
  • Критерии устойчивости
    Это правила, в соответствии с которыми можно установить факт устойчивости или неустойчивости системы и даже судить о степени ее устойчивости по косвенным признакам: виду ЛАЧХ и ЛФЧХ, соотношению между коэффициентами характеристического полинома и др.
  • Контролируемая величина
    Величина, характеризующая объект управления и измеряемая в процессе управления объектом. Неконтролируемая величина - не измеряется.
  • ЛАЧХ (логарифмическая амплитудно-частотная характеристика)
    Это АЧХ, построенная в логарифмическом масштабе.
  • ЛФЧХ (логарифмическая фазочастотная характеристика)
    ФЧХ, построенная в полулогарифмическом масштабе (т.е. только частота откладывается в логарифмическом масштабе).
  • Линейная система
    Это такая, в которой сумме воздействий соответствует реакция, равная сумме реакций на каждое из них, а некоторому изменению воздействия соответствует пропорциональное изменение реакции, т.е. любая линейная система подчинятся принципу суперпозиции. Большинство систем и объектов при достаточно малых воздействиях можно считать линейными.
  • Модель линейной системы
    Совокупность структурно-алгоритмической схемы и передаточных функций ее звеньев или передаточная функция всей системы.
  • Начальные условия
    Значения величины и младших производных решения дифференциального уравнения в нулевой момент времени (сигналов на выходах интеграторов в момент начала моделирования в VisSim'е). Физически это может быть ток в катушке или напряжение на конденсаторе к моменту коммутации цепи, или уровень (объём) воды в водохранилище к моменту начала сброса.
  • Нелинейная САР
    САР, в которой хотя бы один элемент является нелинейным.
  • Нелинейный элемент САР
    Звено, статическая характеристика которого нелинейная, т.е. величина выходного сигнала такого элемента нелинейно зависит от величины входного сигнала.
  • ОС - обратная связь
    Связывает выход элемента или некоторой совокупности элементов с их входом.
  • ООС - отрицательная обратная связь
    Входной сигнал охватываемого ей звена получается вычитанием из входного воздействия выходного сигнала звена или его части. ООС может повысить стабильность системы регулирования.
  • Объект управления
    Машина, механизм, устройство и т.п., способные воспринимать внешние воздействия и реагировать на них изменением некоторой величины, характеризующей объект, например, температуры, напряжения, пространственной координаты и др.
  • Параметр
    Численная величина, характеризующая систему или ее элемент, например, коэффициент усиления, постоянная времени.
  • Передаточная функция
    Функция комплексного аргумента, связывающая изображения Лапласа входного и выходного сигналов линейного звена.
  • Переходная функция
    Реакция (отклик) линейного звена на ступенчатое единичное воздействие. По экспериментальной переходной характеристике объекта или системы можно количественно оценить их устойчивость, колебательность, инерционность, способность к накоплению, усиление. Это позволяет построить модель САР или объекта.
  • Предмет ТАУ
    Анализ и синтез систем автоматического управления.
  • Программное управление
    Осуществление воздействия на объект таким образом, чтобы величина, его характеризующая изменялась во времени в соответствии с заранее известным законом (программой).
  • ПОС - положительная обратная связь
    Входной сигнал охватываемого ей звена получается сложением с воздействием выходного сигнала этого звена или части выходного сигнала. В ТАУ, ПОС зачастую нежелательна, поскольку может привести к потере системой устойчивости.
  • Разомкнутая САР с управлением по возмущению
    Система управления, в которой регулятор вырабатывает управляющие воздействия на объект на основе задания и возмущений, действующих на объект. Информация о реальном значении управляемой величины в регулятор не поступает.
  • Регулирование
    Поддержание постоянной (стабилизация) или изменяющейся по некоторому закону (программное управление или слежение) величины, характеризующей объект управления.
  • САР - система автоматического регулирования
    См. Система в ТАУ
  • САУ - система автоматического управления
    См. Система в ТАУ
  • Синтез системы
    Построение теоретической модели проектируемой САР, соответствующей требуемым критериям ее качества.
  • Система (в ТАУ)
    Совокупность элементов (звеньев), взаимодействующих между собой и предназначенная для выполнения функций управления техническим объектом, в частности, регулирования: слежения и стабилизации. Главный элемент - объект управления. Важный элемент - регулятор.
  • Слежение
    Поддержание с требуемой точностью управляемой, выходной величины объекта управления пропорциональной задающей величине, подаваемой на САР. Пример: слежение оптической оси телескопа за спутником.
  • Стабилизация
    1. Одна из задач регулирования. Поддержание постоянной некоторой величины, характеризующей объект управления, т.е. его управляемой величины, например, температуры в печи.
    2. Приведение неустойчивой САР в устойчивое состояние.
  • Статическая САР
    САР с управлением по отклонению, в контуре которой отсутствуют интеграторы. Ошибка слежения такой САР в статическом режиме пропорциональна отслеживаемой величине.
  • Статический режим работы САР
    Это работа САР при постоянных задающих и возмущающих воздействиях. В таком режиме инерционность САР не проявляется.
  • Статическая характеристика объекта управления
    Зависимость выходной величины объекта у, т.е. величины характеризующей объект управления, от величины подаваемого на его вход воздействия х, при условии, что подаваемое воздействие постоянно, т.е. х = const.
  • Структурная схема (структурно-алгоритмическая схема)
    Теоретическая модель реальной системы, представляющая собой блок-схему, в которой звенья соответствуют математическим операциям преобразования сигналов, а стрелки указывают направление передачи информации. Для одной системы может быть построено несколько эквивалентных и адекватных структурных схем.
  • Устойчивость системы
    Способность системы возвращаться в исходное состояние по окончании воздействия. Устойчивая САР может выполнять задачи слежения и стабилизации лучше или хуже, в то время как неустойчивая САР просто вредна.
  • Управляемая величина
    Величина, характеризующая объект управления и изменяющаяся под воздействием на объект управляющей величины.
  • Управляющая величина
    Величина, поступающая на вход объекта управления. Под воздействием на объект управляющей величины изменяется его управляемая величина.
  • Функциональная схема
    Блок-схема, состоящая из блоков, соответствующим функциональным, физическим элементам системы управления. Стрелки на схеме указывают направление передачи энергии.
  • ФЧХ - фазочастотная характеристика
    Зависимость аргумента комплексного коэффициента передачи некоторого звена от частоты. Другими словами, это зависимость фазовой задержки синусоидального сигнала при прохождении им линейного звена, от частоты.
  • Экстремальное управление
    Поддержание на оптимальном, в определенном смысле, уровне значения величины, характеризующей объект управления. Например, обеспечение максимальной скорости бурения или минимального расхода топлива.

К содержанию >>


0 Вопросы для самопроверки ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки по темам лекций 1 - 4

Ниже предлагаются простые вопросы для самоконтроля по темам лекций первой методической единицы (юниты 1). Вопросы задаются в интерактивном режиме и предназначены для закрепления материала лекций, снабжены системой ссылок, позволяющих переходить от вопроса к вопросу и к разделам лекций по вопросу, на который студент ответил не правильно.

Интерактивный режим предполагает возможность неоднократного возвращения к одному и тому же вопросу без начисления каких-либо штрафных баллов. Не выставляется студенту и общая оценка. Ему предлагается самому оценить твердость своих знаний. Поэтому смысл самоконтроля состоит не в том, чтобы "угадать" правильный ответ, это сделать очень легко, пощелкав несколько раз по ответам, а в том, чтобы разобраться, понять и запомнить, почему он правильный.

Ответы на вопросы снабжены наглядным графическим материалом. Отметим, что в каждом рисунке информации содержится значительно больше, чем в нескольких абзацах текста. Поэтому рекомендуется обстоятельно рассматривать рисунки и запоминать ответы.

  • Тема 1
    Характеристика объектов и систем автоматического управления
  • Тема 2
    Уравнения, модели и характеристики линейных систем
  • Тема 3
    Типовые звенья и идентификация САР
  • Тема 4
    Соединение звеньев и преобразование структурных схем. Типовая схема САР


Федосов Борис Трофимович - Boris T. Fedosov

English

Федосов Борис Трофимович

Федосов Борис Трофимович

Родился в 1950г. , в г. Калининграде, Калининградской обл., РСФСР.
В 1954 г. приехал в Кустанайскую обл. с родителями на целину.
Учился в школах № 7 и №6 г. Рудного и в г. Ленинграде (шк.№331 - 1кл., шк.№497 - 7 кл.). Окончил 10 класс в физматшколе № 165 в Академгородке Новосибирска в 1967 г.
Окончил Новосибирский электротехнический институт в 1973 г., радиоинженер.
С 1973 работает в г. Рудном в РИИ: старшим лаборантом кафедры ЭАГР; с 1974 г. - преподавателем, старшим преподавателем, зав. кафедрой (1982 - 1985 г.) высшей геодезии РИИ.
1980 г. - защитил кандидатскую диссертацию в Московском институте инженеров геодезии, аэрофотосъемки и картографии. Тема диссертации: "Разработка и исследование светодальномеров с активным ответом"
1985 - 1990 г. - зав. кафедрой электротехники РИИ.
С 1981 по 1991 г. - председатель Рудненского отделения Всесоюзного астрономо - геодезического общества при АН СССР.
С 1991 г. и по настоящее время - доцент кафедры АТПиП.
Трудов и изобретений - 45. Основные работы в областях: светодальномерная техника, оптическая длинобазисная интерферометрия, теория автоматического управления. Публикации методических разработок. Публикации в Интернете.
Читал курсы: радиогеодезии; автоматизации высокоточных инженерно-геодезических измерений; электротехники; ТОЭ; ТАУ; телемеханики; программирования и вычислительной техники и др.

E-mail: defbort@mail.kz
Личная страница
http://model.exponenta.ru/bt/bt_fed.html

111500 Казахстан,
Костанайская область. г. Рудный,
ул. 50 Лет Октября, 38
Рудненский индустриальный институт.
http://rii.kz
Кафедра автоматизации технологических процессов и производств
телефон (8-31431) 5-04-01 (доб.131)
или 5-02-80 (доб.131)

22.01.2005

Обновлено 23.04.2008

К содержанию >>


Boris T. Fedosov - Федосов Борис Трофимович

Russian

Boris T. Fedosov

Boris T. Fedosov

Boris Trofimovich Fedosov was born in 1950, in Kaliningrad city, Kaliningrad region, Russia.
In 1954 has arrived to the Kustanay region (Kazakchstan) with the parents on a virgin soil.
Has finished a rate training in 10 classes physmathscool (PhMS) in Novosibirsk Academtown in 1967.
Has finished Novosibirsk electrotechnical institute (NETI) in 1973, radio-engineer.
After 1973 works in Rudniy town (Kazakchstan) in Rudniy Industrial Institute (RII): senior laborant of faculty electrification and automation of mountain works; since 1974 - assistant, senior lecturer, docent, manager (1982 - 1985) faculty highest geodesy RII.
1980 - has defended a candidate thesis in the Moscow institute of the engineers of a geodesy, air photography and cartography (MIIGAaC). A subject of a thesis: "Development and research optical (laser) range meter with active response".
1981 - 1991 - Boris T. Fedosov is chairman of Rudny branch of All-Union Astronomy - Geodetic Society at Academy of Sciences of USSR. .
1985 - 1990 - manager faculty of electrical engineering RII, docent.
1991 - docent (senior lecturer) of faculty of automation of technological processes and production (ATPP).
Proceedings and inventions - 45. The basic activities in areas: distance meter engineering, optical very long base interferometry (VLBI), methodical work. Publications in the Internet
Read rates: radiogeodesies; automation of precision geodetic measurements; electrical engineering; the theories of automatic control; the telemechanics; programming and computer facilities etc.

E-mail: defbort@mail.kz

111500 Kazakhstan,
Kostanay reg., Rudniy town,
50 Let Oktiabria, 38
Rudniy Industrial Institute
http://rii.kz
Faculty of automation of technological processes and production (ATPP)
tel. (8-31431) 5-04-01 (add.131)
or 5-02-80 (add.131)

Content >>

22.01.2005

Is updated 28.09.2006


1 1 Ответ не правильный Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.1

Выберите схему САР с жестким управлением

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 1.1

<< К теме лекций
по вопросу 1.1

<< К списку вопросов
по теме 1


1 2 Ответ не правильный Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.2

Выберите схему разомкнутой САР с управлением по возмущению

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 1.2

<< К теме лекций
по вопросу 1.2

<< К списку вопросов
по теме 1


1 1 Ответ не правильный Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.3

Выберите схему замкнутой САР с управлением по отклонению

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 1.3

<< К теме лекций
по вопросу 1.3

<< К списку вопросов
по теме 1


1 4 Ответ не правильный Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.4

Укажите схему замкнутой САР с комбинированным управлением по отклонению и возмущению

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 1.4

<< К теме лекций
по вопросу 1.4

<< К списку вопросов
по теме 1


1 5 Ответ не правильный Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.5

Укажите схему замкнутой САР с экстремальным управлением

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 1.5

<< К теме лекций
по вопросу 1.5

<< К списку вопросов
по теме 1


2 1 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.1

Что такое ступенчатая единичная функция (функция включения, функция Хевисайда)?

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 2.1

<< К теме лекций
по вопросу 2.1

<< К списку вопросов
по теме 2


2 2 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.2

Что такое переходная функция линейной системы?

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 2.2

<< К теме лекций
по вопросу 2.1

<< К списку вопросов
по теме 2


2 3 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.3

Как узнать амплитуду выходного сигнала линейной системы, если на ее входе действует синусоидальный сигнал частоты ω = 14 рад/сек?

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 2.3

<< К теме лекций
по вопросу 2.1

<< К списку вопросов
по теме 2


2 4 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.4

Как узнать по ЛАЧХ и ЛФЧХ усиление линейной системы и ее фазовую задержку на некоторой частоте?

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 2.4

<< К теме лекций
по вопросу 2.1

<< К списку вопросов
по теме 2


2 5 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.5

Укажите основные характеристики линейной системы.

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 2.5

<< К теме лекций
по вопросу 2.5

<< К списку вопросов
по теме 2


3 1 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.1

Укажите передаточную функцию интегратора, его переходную функцию, ЛАЧХ и ЛФЧХ

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 3.1

<< К теме лекций
по вопросу 3.1

<< К списку вопросов
по теме 3


3 2 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.2

Укажите передаточную функцию апериодического звена , его переходную функцию, ЛАЧХ и ЛФЧХ

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 3.2

<< К теме лекций
по вопросу 3.2

<< К списку вопросов
по теме 3


3 3 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.3

Укажите передаточную функцию колебательного звена, его переходную функцию

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 3.3

<< К теме лекций
по вопросу 3.3

<< К списку вопросов
по теме 3


3 4 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.4

Укажите ЛАЧХ и ЛФЧХ колебательного звена

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 3.4

<< К теме лекций
по вопросу 3.4

<< К списку вопросов
по теме 3


3 5 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.5

Укажите ЛАЧХ и ЛФЧХ колебательного звена

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 3.5

<< К теме лекций
по вопросу 3.5

<< К списку вопросов
по теме 3


4 1 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.1

Указать формулы передаточной функции, ЛАЧХ и ЛФЧХ последовательного соединения двух звеньев

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 4.1

<< К теме лекций
по вопросу 4.1

<< К списку вопросов
по теме 4


4 2 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.2

Указать формулы передаточной и переходной функций параллельного согласного соединения двух звеньев

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 4.2

<< К теме лекций
по вопросу 4.2

<< К списку вопросов
по теме 4


4 3 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.3

Указать формулу передаточной функции параллельного встречного соединения двух звеньев

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 4.3

<< К теме лекций
по вопросу 4.3

<< К списку вопросов
по теме 4


4 4 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.4

Определить моменты времени, в которые на САР поступает ступенчатое изменение задания и на объект управления поступает ступенчатое изменение возмущения

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 4.4

<< К теме лекций
по вопросу 4.4

<< К списку вопросов
по теме 4


4 5 Ответ не правильный Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.5

Определить моменты времени, в которые на САР поступает ступенчатое изменение задания и на объект управления поступает ступенчатое изменение возмущения

Ответ не правильный!
Попробуйте еще раз.

<< Назад
к вопросу 4.5

<< К теме лекций
по вопросу 4.5

<< К списку вопросов
по теме 4


1 1 Ответ правильный ТАУ ЮНИТА 1 Самопроверка 1 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.1

Выберите схему разомкнутой САР с жестким управлением

Ответ правильный!

САР обеспечивает пропорциональность управляемой величины задающей величине. Возмущение либо пренебрежимо мало, либо вычислено заранее и учтено в задании.

Далее к
вопросу 1.2 >>

<< К списку вопросов
по теме 1


1 2 Ответ правильный ТАУ ЮНИТА 1 Самопроверка 1 2

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.2

Выберите схему разомкнутой САР с управлением по возмущению

Ответ правильный!

САР обеспечивает пропорциональность управляемой величины задающей величине. Регулятор на основе оценки возмущения корректирует управляющую величину.

Далее к
вопросу 1.3 >>

<< К списку вопросов
по теме 1


1 3 Ответ правильный ТАУ ЮНИТА 1 Самопроверка 1 3

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.3

Выберите схему замкнутой САР с управлением по отклонению

Ответ правильный!

САР обеспечивает пропорциональность управляемой величины задающей величине сравнивая их величины и устремляя их разность к нулю.

Далее к
вопросу 1.4 >>

<< К списку вопросов
по теме 1


1 4 Ответ правильный ТАУ ЮНИТА 1 Самопроверка 1 4

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.4

Укажите схему замкнутой САР с комбинированным управлением по отклонению и возмущению

Ответ правильный!

САР обеспечивает пропорциональность управляемой величины задающей величине сравнивая их величины и устремляя их разность к нулю. Кроме того, регулятор формирует управляющую величину и на основе возмущения. Т.о. САР осуществляет как слежение за задающей величиной, так и стабилизацию, подавление влияния возмущения на управляющую величину.

Далее к
вопросу 1.5 >>

<< К списку вопросов
по теме 1


1 5 Ответ правильный ТАУ ЮНИТА 1 Самопроверка 1 5

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.5

Укажите схему замкнутой САР с экстремальным управлением

Ответ правильный!

САР подбирает оптимальное значение управляющей величины так, чтобы управляемая величина достигала экстремума (максимума или минимума).

<< К списку вопросов
по теме 1


2 1 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.1

Что такое ступенчатая единичная функция (функция включения, функция Хевисайда)?

Ответ правильный!

До начального, нулевого момента времени сигнал равен нулю, а в нулевой момент времени он становится равным единице и остается таким в дальнейшем.

Далее к
вопросу 2.2 >>

<< К списку вопросов
по теме 2


2 2 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.2

Что такое переходная функция линейной системы?

Ответ правильный!

Системы инерционны и поэтому при резком, ступенчатом воздействии они реагируют на него постепенно. Реакция может монотонно или колебательно расти к некоторому уровню в случае устойчивой системы.

Далее к
вопросу 2.3 >>

<< К списку вопросов
по теме 2


2 3 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.3

Как узнать амплитуду выходного сигнала линейной системы, если на ее входе действует синусоидальный сигнал частоты ω = 14 рад/сек?

Ответ правильный!

Если на входе линейной системы действует синусоидальный сигнал, то на ее выходе сигнал также синусоидальный, той же частоты, но с другими амплитудой и начальной фазой. Амплитуда выходного синусоидального сигнала равна произведению амплитуды входного сигнала на значение модуля комплексного коэффициента передачи на частоте 14 рад/сек.

Далее к
вопросу 2.4 >>

<< К списку вопросов
по теме 2


2 4 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.4

Как узнать по ЛАЧХ и ЛФЧХ усиление линейной системы и ее фазовую задержку на некоторой частоте?

Ответ правильный!

По ЛАЧХ определяется значение усиления в дБ, которое можно перевести в краты (разы) по формуле k = 10(L, дБ)/20

Далее к
вопросу 2.5 >>

<< К списку вопросов
по теме 2


2 5 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.5

Укажите основные характеристики линейной системы.

Ответ правильный!

<< К списку вопросов
по теме 2


3 1 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.1

Укажите передаточную функцию интегратора, его переходную функцию, ЛАЧХ и ЛФЧХ

Ответ правильный!

Какой наклон имеет ЛАЧХ и на какой частоте она пересекает ось частот на уровне 0 дБ?
Как определить постоянную времени интегратора по его переходной характеристике?

Далее к
вопросу 3.2 >>

<< К списку вопросов
по теме 3


3 2 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.2

Укажите передаточную функцию апериодического звена, его переходную функцию, ЛАЧХ и ЛФЧХ

Ответ правильный!

Чем и как определяется время завершения переходного процесса апериодического звена?
Длительность его переходного процесса равна утроенному значению постоянной времени

Далее к
вопросу 3.3 >>

<< К списку вопросов
по теме 3


3 3 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.3

Укажите передаточную функцию колебательного звена, его переходную функцию

Ответ правильный!

Чем и как определяется время завершения переходного процесса колебательного звена?

Далее к
вопросу 3.4 >>

<< К списку вопросов
по теме 3


3 4 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.4

Чем и как определяется время завершения переходного процесса колебательного звена?

Ответ правильный!

Чем и как определяется время частота резонансного пика ЛАЧХ колебательного звена?
Чему равна на этой частоте фазовая задержка колебательного звена?

Далее к
вопросу 3.5 >>

<< К списку вопросов
по теме 3


3 5 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.5

Укажите передаточную функцию звена запаздывания, его переходную функцию

Ответ правильный!

Это ступенчатая функция, задержанная на величину запаздывания (красная линия).

<< К списку вопросов
по теме 3


4 1 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.1

Указать формулы передаточной функции, ЛАЧХ и ЛФЧХ последовательного соединения двух звеньев

Ответ правильный!

Далее к
вопросу 4.2 >>

<< К списку вопросов
по теме 4


4 2 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.2

Указать формулы передаточной и переходной функций параллельного согласного соединения двух звеньев

Ответ правильный!

Далее к
вопросу 4.3 >>

<< К списку вопросов
по теме 4


4 3 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.3

Указать формулу передаточной функции параллельного встречного соединения двух звеньев

Ответ правильный!

Далее к
вопросу 4.4 >>

<< К списку вопросов
по теме 4


4 4 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.4

Определить моменты времени, в которые на САР поступает ступенчатое изменение задания и на объект управления поступает ступенчатое изменение возмущения

Ответ правильный!

Далее к
вопросу 4.5 >>

<< К списку вопросов
по теме 4


4 5 Ответ правильный ТАУ ЮНИТА 1 Самопроверка

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.5

Определить тип звеньев модели объекта, составленной из последовательного соединения типовых звеньев, а также передаточную функцию модели.

Ответ правильный!

Порядок определения состава звеньев и их параметров

ЛАЧХ последовательного соединения звеньев равна сумме ЛАЧХ отдельных звеньев.

В области нижних частот ЛАЧХ проходит с наклоном -20 дБ/дек, поэтому в последовательной модели имеется интегратор.

Коэффициент усиления всей совокупности последовательно соединенных звеньев определяется в данном случае коэффициентом усиления интегратора, который равен частоте точки пересечения линии аппроксимации ЛАЧХ, имеющей наклон - 20 дБ/дек, с осью частот.

На частоте 1 рад/сек наклон аппроксимации ЛАЧХ изменяется с - 20 дБ/дек до - 40 дБ/дек, такое изменение может сделать только апериодическое звено с постоянной времени Т1 = 1/(1 рад/сек) = 1 сек.

На частоте 10 рад/сек наклон аппроксимации ЛАЧХ вновь изменяется на -20 дБ/дек, с - 40 дБ/дек до - 60 дБ/дек, т.е. и здесь "включается в работу" также апериодическое звено с постоянной времени Т2 = 1/(10 рад/сек) = 0.1 сек.

Таким образом, в модель входят интегратор и два апериодических звена

Рис. (анимация 4 кадра). Порядок определения параметров звеньев

Отметим, что колебательное звено изменило бы наклон ЛАЧХ сразу на - 40 дБ/дек, а например, форсирующее звено изменило бы наклон ЛАЧХ на +20 дБ/дек.

<< К списку вопросов
по теме 4


1 1 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.1

Выберите схему разомкнутой САР с жестким управлением и щелкните по ней левой кнопкой мыши

К следующему
вопросу 1.2 >>

<< К списку вопросов
по теме 1


1 2 Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.2

Выберите схему разомкнутой САР с управлением по возмущению и щелкните по ней левой кнопкой мыши

К следующему
вопросу 1.3 >>

<< К списку вопросов
по теме 1


1 3 Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.3

Выберите схему замкнутой САР с управлением по отклонению

К следующему
вопросу 1.4 >>

<< К списку вопросов
по теме 1


1 4 Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.4

Укажите схему замкнутой САР с комбинированным управлением по отклонению и возмущению и щелкните по ней левой кнопкой мыши

К следующему
вопросу 1.5 >>

<< К списку вопросов
по теме 1


1 5 Самопрверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 1.5

Укажите схему замкнутой САР с экстремальным управлением и щелкните по ней левой кнопкой мыши

<< К списку вопросов
по теме 1


2 1 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.1

Что такое ступенчатая единичная функция (функция включения, функция Хевисайда)?

К следующему
вопросу 2.2 >>

<< К списку вопросов
по теме 2


2 2 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.2

Что такое переходная функция линейной системы?

К следующему
вопросу 2.3 >>

<< К списку вопросов
по теме 2


2 3 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.3

Как узнать амплитуду выходного сигнала линейной системы, если на ее входе действует синусоидальный сигнал частоты ω = 14 рад/сек?

К следующему
вопросу 2.4 >>

<< К списку вопросов
по теме 2


2 4 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.4

Как узнать по ЛАЧХ и ЛФЧХ усиление линейной системы и ее фазовую задержку на некоторой частоте?

Прочитать эти значения по ЛАЧХ и ЛФЧХ на этой частоте.

По ЛАЧХ значение усиления определяется в дБ, его можно перевести в краты (разы) по формуле k = 10(L, дБ)/20

К следующему
вопросу 2.5 >>

<< К списку вопросов
по теме 2


2 5 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 2.5

Укажите основные характеристики линейной системы.

<< К списку вопросов
по теме 2


3 1 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.1

Укажите передаточную функцию интегратора, его переходную функцию, ЛАЧХ и ЛФЧХ и щелкните по ним левой кнопкой мыши

К следующему
вопросу 3.2 >>

<< К списку вопросов
по теме 3


3 2 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.2

Укажите передаточную функцию апериодического звена, его переходную функцию, ЛАЧХ и ЛФЧХ

К следующему
вопросу 3.3 >>

<< К списку вопросов
по теме 3


3 3 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.3

Укажите передаточную функцию колебательного звена, его переходную функцию

К следующему
вопросу 3.4 >>

<< К списку вопросов
по теме 3


3 4 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.4

Укажите ЛАЧХ и ЛФЧХ колебательного звена

К следующему
вопросу 3.5 >>

<< К списку вопросов
по теме 3


3 5 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 3.5

Укажите передаточную функцию звена запаздывания, его переходную функцию

<< К списку вопросов
по теме 3


4 1 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.1

Указать формулы передаточной функции, ЛАЧХ и ЛФЧХ последовательного соединения двух звеньев

К следующему
вопросу 4.2 >>

<< К списку вопросов
по теме 4


4 2 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.2

Указать формулы передаточной и переходной функций параллельного согласного соединения двух звеньев

К следующему
вопросу 4.3 >>

<< К списку вопросов
по теме 4


4 3 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.3

Указать формулу передаточной функции параллельного встречного соединения двух звеньев

К следующему
вопросу 4.4 >>

<< К списку вопросов
по теме 4


4 4 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.4

Определить моменты времени, в которые на САР поступает ступенчатое изменение задания и на объект управления поступает ступенчатое изменение возмущения

Укажите ответ

К следующему
вопросу 4.5 >>

<< К списку вопросов
по теме 4


4 5 Самопроверка ТАУ ЮНИТА 1

КУРС: ТЕОРИЯ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ
Юнита 1. Математическое описание линейных систем
и их элементов

Вопросы для самопроверки

Вопрос 4.5

Даны экспериментально снятые ЛАЧХ и ЛФЧХ некоторого объекта.

Определить тип звеньев модели объекта, составленной из последовательного соединения типовых звеньев, а также передаточную функцию модели.

Укажите ответ

<< К списку вопросов
по теме 4